Results 1 to 5 of 5

Thread: Broken installation- unmet dependency of package libreoffice

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2015-Oct
    Location
    Pune
    Posts
    4

    Broken installation- unmet dependency of package libreoffice

    Hi ,

    Im not able to install anything by using apt-get as it is showing some "broken install error " related to libreoffice , please find below output and help me to sort it out issue

    OS : kali rolling
    laptop: lenovo g480

    Troubleshooting done:

    update your package list like this

    sudo apt-get update

    then cleanup any partial packages

    sudo apt-get autoclean

    Now clean the apt cache

    sudo apt-get clean

    Now remove any unnecessary dependancies

    sudo apt-get autoremove

    from the command above, you can identify any broken packages and forcefully remove it like this

    sudo dpkg --remove --force-remove-reinstreq package_name

    Finally mopup any other packages with dependacies

    sudo apt-get -f install



    Error messages:


    root@kali:/hack/wifiphisher-1.2# apt-get install tree
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    libreoffice-core : Depends: libreoffice-common (> 1:5.4.1) but it is not going to be installed
    libreoffice-java-common : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-ogltrans : Depends: libreoffice-common but it is not going to be installed
    libreoffice-report-builder : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-bsh : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-js : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-python : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-style-galaxy : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    wifi-pumpkin : Depends: libssl-dev but it is not going to be installed
    Depends: libxml2-dev but it is not going to be installed
    Depends: libxslt1-dev but it is not going to be installed
    Depends: zlib1g-dev but it is not going to be installed
    Depends: libarchive-dev but it is not going to be installed
    Depends: libnetfilter-queue-dev but it is not going to be installed
    Depends: libpcap-dev but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:/hack/wifiphisher-1.2#


    im work on it from last 2 days but im not able to fix it , please help me friends

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    1,012
    dpkg --remove libreoffice && apt purge libreoffice

  3. #3
    Join Date
    2015-Oct
    Location
    Pune
    Posts
    4
    Tried but still its showing below error..


    root@kali:/hack/wifiphisher-1.1# dpkg --remove libreoffice && apt purge libreoffice
    (Reading database ... 354826 files and directories currently installed.)
    Removing libreoffice (1:5.4.1-1) ...
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package 'libreoffice' is not installed, so not removed
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    libreoffice-core : Depends: libreoffice-common (> 1:5.4.1) but it is not going to be installed
    libreoffice-java-common : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-ogltrans : Depends: libreoffice-common but it is not going to be installed
    libreoffice-report-builder : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-bsh : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-js : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-python : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-style-galaxy : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    wifi-pumpkin : Depends: libssl-dev but it is not going to be installed
    Depends: libxml2-dev but it is not going to be installed
    Depends: libxslt1-dev but it is not going to be installed
    Depends: zlib1g-dev but it is not going to be installed
    Depends: libarchive-dev but it is not going to be installed
    Depends: libnetfilter-queue-dev but it is not going to be installed
    Depends: libpcap-dev but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:/hack/wifiphisher-1.1#

  4. #4
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    1,012
    Try only apt purge libreoffice

  5. #5
    Join Date
    2017-Dec
    Posts
    1
    Quote Originally Posted by mithz View Post
    Hi ,

    Im not able to install anything by using apt-get as it is showing some "broken install error " related to libreoffice , please find below output and help me to sort it out issue

    OS : kali rolling
    laptop: lenovo g480

    Troubleshooting done:

    update your package list like this

    sudo apt-get update

    then cleanup any partial packages

    sudo apt-get autoclean

    Now clean the apt cache

    sudo apt-get clean

    Now remove any unnecessary dependancies

    sudo apt-get autoremove

    from the command above, you can identify any broken packages and forcefully remove it like this

    sudo dpkg --remove --force-remove-reinstreq package_name

    Finally mopup any other packages with dependacies

    sudo apt-get -f install



    Error messages:


    root@kali:/hack/wifiphisher-1.2# apt-get install tree
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    libreoffice-core : Depends: libreoffice-common (> 1:5.4.1) but it is not going to be installed
    libreoffice-java-common : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-ogltrans : Depends: libreoffice-common but it is not going to be installed
    libreoffice-report-builder : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-bsh : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-js : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-script-provider-python : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    libreoffice-style-galaxy : Depends: libreoffice-common (= 1:5.4.1-1) but it is not going to be installed
    wifi-pumpkin : Depends: libssl-dev but it is not going to be installed
    Depends: libxml2-dev but it is not going to be installed
    Depends: libxslt1-dev but it is not going to be installed
    Depends: zlib1g-dev but it is not going to be installed
    Depends: libarchive-dev but it is not going to be installed
    Depends: libnetfilter-queue-dev but it is not going to be installed
    Depends: libpcap-dev but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    root@kali:/hack/wifiphisher-1.2#


    im work on it from last 2 days but im not able to fix it , please help me friends

    Remember what dependencies is troubling and landing in broken install.....


    follow it

    apt-get install libreoffice-style-tango ure ...........................or any other shows like your one

    Depends: libxml2-dev but it is not going to be installed
    Depends: libxslt1-dev but it is not going to be installed
    Depends: zlib1g-dev but it is not going to be installed
    Depends: libarchive-dev but it is not going to be installed
    Depends: libnetfilter-queue-dev but it is not going to be installed
    Depends: libpcap-dev but it is not going to be installed


    was absent while installing.


    so I had to install it after
    sudo apt-get autoclean $$ apt-get clear cache


    install missing packages....

    apt-get update
    sudo dpkg --remove --force-remove-reinstreq package_name
    apt-get --force-rewrite ,........ -f-broken install
    solves the problem of libre office install



    done

    Thanks

Similar Threads

  1. Update issue - broken package
    By natv in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-09-23, 17:35
  2. Replies: 0
    Last Post: 2015-06-30, 03:10
  3. Need Help with broken package
    By xe1phex in forum General Archive
    Replies: 0
    Last Post: 2014-06-30, 16:45
  4. psad dependency problem (virtual package)
    By moh in forum General Archive
    Replies: 3
    Last Post: 2013-05-08, 12:34

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •