Results 1 to 2 of 2

Thread: Sound doesnt work

  1. #1
    Join Date
    2017-Oct
    Posts
    4

    Sound doesnt work

    Hello All,

    Unfortunately, sound doesn't work on my Kali Linux and I have no clue why. I tried multiple fixes that I found, none of them worked. I have Kali 64bit 2017.2, and here is what I tried:

    Reinstall Kali on USB (I have persistence version, but sound didnt work even with live).

    systemctl --user enable pulseaudio && systemctl --user start pulseaudio

    curl -s https://raw.githubusercontent.com/nu.../pulseaudio.sh | bash

    pulseaudio -D

    (When I did these steps, I had to reinstall kali :/ )
    sudo apt-get purge pulseaudio pulseaudio-utils gstreamer0.10-pulseaudio paman pavumeter pavucontrol
    rm ~/ .pulse-cookie ,r m -r ~/ .pulse
    sudo apt-get install alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss alsamixergui libalsaplayer0

    So to be honest, im desperate now. Can someone with advanced knowledge of Linux - Debian help me ?

    Here is my adapter:
    Audio device: Intel Corporation Device a171 (rev 31)

    Thank you in advance!

  2. #2
    Join Date
    2016-Jul
    Posts
    14
    Whenever I've found myself without sound, after experiencing the issue many times and tried many ways, this is what I ALWAYS do and have done. (As recent as a few months ago after installing on varying machines.)

    In terminal...

    root@kali:~#apt-get install alsa-utils -y

    root@kali:~#systemctl --user enable pulseaudio && systemctl --user start pulseaudio



    ...RESTART

    That's it.
    Last edited by atdtphreaker; 2017-11-02 at 09:12.

Similar Threads

  1. Replies: 1
    Last Post: 2017-09-23, 08:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •