In the apt i am living now, I don't have Internet, except for my phone, which has 5 gb per month before i am throttled down. I live near a university with free public wifi, which i use when i am there, and can pick up weakly from one window in the apt, and only on my oldest laptop, with a big screen.

I brought a Alfa AWUS036NH card with a 7dB flat panel antenna few days ago on amazon.

The reason i brought this card was that the sell stated "802.11b/g and "N", 2000mW of power which is more powerful than ANY other WiFi adapter on the market"

I checked the Debian forms which made with recommended that apt-get install firmware-ralink and
apt-get install firmware-misc-nonfree. Which are up to date.

The software on the card looks ok, since when i connect to my phone, it holds the connection ok. I went the a library at the University, and the card worked ok.

But then i connect from home, i get no internet even though i have a stronger connection, then i do with my old laptop, which can get internet.

On the laptop, using wavemon i get screenshot: (I tried to upload image, keep getting error.)

link quality 51% (36/70)
Signal level -74 dBm
noise level -95 dBm
SNR 21 dB

Did a speed test, and i got:

When i connect with the Alfa card i get:

link quality 74% (52/70)
signal level -58 dBm (1.58 nw)

But i don't get any internet access, even though i have a better link at 74%.
I notice that the SNR is missing?

When i am in the University library, I get

link quality 100% (70/70)
signal level -39 dBm (0.13 uW)

In the library the card works fine. So it should not be a driver issue.

screenshot of ifconfig is:

wavemon scan show this from inside the library.


root@kali:~# uname -rv
4.13.0-kali1-amd64 #1 SMP Debian 4.13.10-1kali2 (2017-11-08)

I don't know how to trouble shoot this. I don't think it the drivers, since i am able to connect while at the university library.

I did search a few different forms before posting, and i did read that sometimes the alfa cards draw too much power from the usb, and cause trouble. This is a 2000mW card. The old post was about a 500 mW card. But i don't understand why if that is the case, when i am in the library or connected to my phone, I do have an Internet connection and the connection is stable?

I could by a usb hub, if i need to. But i don't want to go out and buy it, to find it does not help.

I do not understand why i can get a connection with my old windows vista era laptop, running kali linux with a weaker connection connection, and cannot with the alfa card.

If it's the connections strength i was thinking of buying a used satellite dish, and putting the flat panel antenna at the focal point, to increase reception. But the reception on the card is stronger then my old laptop, and i get no Internet.

All this confuses me, not sure how to trouble shoot.

Thank you.