Results 1 to 5 of 5

Thread: Running apt-get dist-upgrade in 2017-02 breaks VM copy/paste and drag/drop

  1. #1
    Junior Member
    Join Date
    Nov 2017
    Posts
    5

    Running apt-get dist-upgrade in 2017-02 breaks VM copy/paste and drag/drop

    As of 12 NOV 2017, running apt-get dist-upgrade on Kali 2017-02 as a VM breaks the ability to drag/drop and copy/paste between the host and guest. This is true both for VMWare Tools and open-vm-tools. Both work fine before doing the dist-upgrade. Doing apt-get upgrade doesn't break this functionality. I'm not sure which package in the dist-upgrade is breaking it.

    Steps to reproduce:
    1. Install Kali 2017-02 as a VM
    2. Install VMWare Tools or open-vm-tools
    3. Do apt-get dist-upgrade
    4. Reboot

    After reboot copy/paste and drag/drop will no longer function. Anyone know what package might be breaking this and I can just roll that one back? Thanks.

  2. #2
    Junior Member
    Join Date
    Nov 2017
    Posts
    5
    Here's the output of apt-get dist-upgrade on a fresh install after doing an apt-get upgrade

    Code:
    Reading package lists...
    Building dependency tree...
    Reading state information...
    Calculating upgrade...
    The following packages were automatically installed and are no longer required:
      casefile libbind9-140 libdns162 libemu2 libfwupd1 libgtkspell3-3-0 libisc160
      libisccfg140 libllvm3.9 liblouis12 liblwgeom-2.3-0 libmozjs-24-0
      libopencv-calib3d2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5
      libopencv-flann2.4v5 libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5
      libopencv-objdetect2.4v5 libopencv-video2.4v5 libpython3.5
      libpython3.5-minimal libpython3.5-stdlib libqgis-core2.14.18
      libqgis-gui2.14.18 libqgis-networkanalysis2.14.18 libqgispython2.14.18
      libradare2-1.6 libtracker-control-1.0-0 libtracker-miner-1.0-0
      libtracker-sparql-1.0-0 libva-drm1 libva-x11-1 libva1 maltegoce peepdf
      python-brotlipy python-pylibemu python-unicorn
    Use 'apt autoremove' to remove them.
    The following packages will be REMOVED:
      gir1.2-mutter-3.0 gir1.2-totem-plparser-1.0 libgjs0e libmutter0i
      libqgis-analysis2.14.18 libqgis-server2.14.18 tracker-gui
    The following NEW packages will be installed:
      e2fsprogs-l10n gir1.2-geoclue-2.0 gir1.2-mutter-1 gir1.2-rsvg-2.0
      gir1.2-totemplparser-1.0 libbind9-141 libblockdev-crypto2 libblockdev-fs2
      libblockdev-loop2 libblockdev-part-err2 libblockdev-part2 libblockdev-swap2
      libblockdev-utils2 libblockdev2 libcharls1 libdata-dump-perl
      libdns-export190 libdns190 libegl-mesa0 libegl1 libfabric1 libfwupd2
      libgdcm2.8 libgdk-pixbuf2.0-bin libgjs0g libgl1 libgl2ps1.4 libgles2
      libglvnd-core-dev libglvnd-dev libglvnd0 libglx-mesa0 libglx0
      libhdf5-openmpi-100 libisc-export189 libisc189 libisccfg144 liblept5
      libllvm5.0 liblouis14 liblwgeom-2.4-0 libmozjs-52-0 libmutter-1-0
      libnetcdf-c++4 libnetcdf13 libnetfilter-queue1 libopencv-calib3d3.2
      libopencv-contrib3.2 libopencv-core3.2 libopencv-features2d3.2
      libopencv-flann3.2 libopencv-highgui3.2 libopencv-imgcodecs3.2
      libopencv-imgproc3.2 libopencv-ml3.2 libopencv-objdetect3.2
      libopencv-photo3.2 libopencv-shape3.2 libopencv-stitching3.2
      libopencv-superres3.2 libopencv-video3.2 libopencv-videoio3.2
      libopencv-videostab3.2 libopencv-viz3.2 libopengl0 libopenmpi2
      libpsm-infinipath1 libpython3.6 libqgis-analysis2.14.20 libqgis-core2.14.20
      libqgis-gui2.14.20 libqgis-networkanalysis2.14.20 libqgis-server2.14.20
      libqgispython2.14.20 libradare2-2.0 libsocket++1 libtesseract-data
      libtesseract3 libtracker-control-2.0-0 libtracker-miner-2.0-0
      libtracker-sparql-2.0-0 libva-drm2 libva-x11-2 libva2 libvolume-key1
      libvtk6.3 maltego nmap-common openmpi-bin openmpi-common postgresql-10
      postgresql-client-10 python-aes python-brotli python-peepdf python3-debconf
      ruby-unicode-display-width switcheroo-control thin-provisioning-tools
      unicorn-magic
    The following packages will be upgraded:
      bind9-host commix debconf debconf-i18n dnsutils e2fslibs e2fsprogs gdal-bin
      gdb gir1.2-gdkpixbuf-2.0 gir1.2-javascriptcoregtk-4.0 gir1.2-totem-1.0
      gir1.2-webkit2-4.0 gjs gnome-characters gnome-control-center
      gnome-control-center-data gnome-disk-utility gnome-online-miners
      gnome-session gnome-session-bin gnome-session-common gnome-settings-daemon
      gnome-shell gnome-shell-common gnome-shell-extension-workspacestodock
      gnome-shell-extensions gnome-software gnome-software-common gnome-sushi
      gnome-tweak-tool grilo-plugins-0.3 gstreamer1.0-libav
      gstreamer1.0-plugins-bad i965-va-driver isc-dhcp-client kali-linux-full
      libavcodec57 libavfilter6 libavformat57 libavresample3 libavutil55
      libegl1-mesa libgbm1 libgdal20 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
      libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles2-mesa
      libgstreamer-plugins-bad1.0-0 libisccc140 libjavascriptcoregtk-4.0-18
      liblwgeom-dev liblwres141 libnautilus-extension1a libosmesa6 libpeas-1.0-0
      libpostproc54 libqgis-customwidgets libradare2-dev libswresample2
      libswscale4 libtotem0 libvdpau-va-gl1 libwayland-egl1-mesa
      libwebkit2gtk-4.0-37 libwww-perl libxatracker2 lvm2 maltegoce
      mesa-common-dev mesa-va-drivers mesa-vdpau-drivers mitmproxy mutter
      mutter-common nautilus nautilus-data ndiff nmap peepdf postgresql
      python-gdal python-qgis python-qgis-common python-qscintilla2 python-qt4
      python-qt4-sql python-sip python-unicorn python3-louis radare2
      ruby-terminal-table thc-ipv6 totem totem-common totem-plugins tracker
      tracker-extract tracker-miner-fs udisks2 vim vim-common vim-gtk
      vim-gui-common vim-runtime vim-tiny xwayland
    111 upgraded, 100 newly installed, 7 to remove and 0 not upgraded.
    Need to get 296 MB of archives.
    After this operation, 428 MB of additional disk space will be used.
    Do you want to continue? [Y/n]

  3. #3
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    731
    I would file a bug report on bugs.kali.org. Try to reproduce this problem on another PC.

    Based on the output of dist-upgrade I'm not able to figure out which package is responsible for this. It can be a problem with the kernel itself.

  4. #4
    Junior Member
    Join Date
    Nov 2017
    Posts
    5
    The only thing I'm sure of is that it's not the kernel because I manually upgraded to 4.13 after doing apt-get upgrade but NOT doing apt-get dist-upgrade and I still retained the ability to copy/paste and drag/drop. I'm not even sure this is a bug in Kali. It might be in an upstream package. That's why I was hoping to narrow it down.

  5. #5
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    731
    File a bug report.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •