Results 1 to 7 of 7

Thread: Now visible networks using usb wireless vmware

  1. #1
    Join Date
    2017-Nov
    Posts
    12

    Now visible networks using usb wireless vmware

    Hi,
    ..of course it is "No visible networks using usb wireless vmware"...

    I have latest kali linux on vmware on win7
    I connected tl-link wn7200 wireless adapter and i can see the wireless icon in Kali but whne i try to connect to a network there are none visible,
    I also diconnected the network connection to leave only wirless.
    I tried to set:
    Code:
    ifconfig wlan0 up
    but it always appear down

    Code:
    iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry short  long limit:2   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    i tried to set it up

    Code:
    sudo ifconfig wlan0 up
    ip link show
    see image:
    Capture.JPG

    I tried to scan, i see the wifi blinking and i get:
    Code:
    root@kali:~# sudo iwlist wlan0 scanning
    wlan0     No scan results
    when i reconnect the usb to the host i see the networks.



    Pleae,
    What can i do?
    Last edited by janjan; 2017-12-01 at 11:15.

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    758
    First of all, does the adapter work in Kali outside of a virtual machine? Personally, I've always found wireless in a VM to be problematic.

  3. #3
    Join Date
    2017-Nov
    Posts
    12
    yes, as i've mentioned in the origial post: when i reconnect the usb to the host i see the networks.
    it is working fine on the host machine

  4. #4
    Join Date
    2016-Dec
    Posts
    218
    Look at dmesg, it might indicate there is something wrong. If using Virtualbox, did you install the extension pack for your CURRENT version?

    Since you mention it's a VM, is the USB set to the correct version (2.0 or 3.0)?

    What driver is it (airmon-ng can tell you)?

  5. #5
    Join Date
    2017-Nov
    Posts
    12
    Thank you,
    Yes I have the extension pack and it is usb 2.0 (this also happens on vmware)

    I've attached the output of below.

    airmon-ng :

    PHY Interface Driver Chipset

    phy0 wlan0 rt2800usb Ralink Technology, Corp. RT2870/RT3070

    dmesg
    *****
    the usb part is this:

    [ 80.358485] usb 1-1: new high-speed USB device number 2 using ehci-pci
    [ 80.671000] usb 1-1: New USB device found, idVendor=148f, idProduct=3070
    [ 80.671003] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 80.671005] usb 1-1: Product: 802.11 n WLAN
    [ 80.671007] usb 1-1: Manufacturer: Ralink
    [ 80.671009] usb 1-1: SerialNumber: 1.0

    there are some erros though at the end which may shed some light:

    13.192722] usb 1-1: reset high-speed USB device number 2 using ehci-pci
    [ 13.551025] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 detected
    [ 14.004523] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0005 detected
    [ 14.021241] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
    [ 14.021579] usbcore: registered new interface driver rt2800usb
    [ 14.145440] vboxsf: Successfully loaded version 5.2.2 (interface 0x00010004)
    [ 18.164045] VBoxService 5.2.2 r119230 (verbosity: 0) linux.amd64 (Nov 22 2017 17:22:52) release log
    00:00:00.000203 main Log opened 2017-12-01T20:08:32.974574000Z
    [ 18.164115] 00:00:00.000308 main OS Product: Linux
    [ 18.164144] 00:00:00.000342 main OS Release: 4.13.0-kali1-amd64
    [ 18.164170] 00:00:00.000370 main OS Version: #1 SMP Debian 4.13.10-1kali2 (2017-11-08)
    [ 18.164208] 00:00:00.000397 main Executable: /opt/VBoxGuestAdditions-5.2.2/sbin/VBoxService
    00:00:00.000398 main Process ID: 527
    00:00:00.000398 main Package type: LINUX_64BITS_GENERIC
    [ 18.165060] 00:00:00.001250 main 5.2.2 r119230 started. Verbose level = 0
    [ 18.847254] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 18.848961] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 18.855759] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
    [ 18.856056] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 18.877297] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 18.877331] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
    [ 18.912982] rt2800usb 1-1:1.0: firmware: direct-loading firmware rt2870.bin
    [ 18.912989] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.36
    [ 22.037885] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 23.725950] fuse init (API version 7.26)
    [ 25.656768] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 26.194151] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 58.172034] rfkill: input handler disabled
    [ 62.234113] ISO 9660 Extensions: Microsoft Joliet Level 3
    [ 62.258963] ISO 9660 Extensions: RRIP_1991A
    [ 330.102619] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 630.981861] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0208 with error -110
    [ 631.097400] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0208 with error -110
    [ 631.209328] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x0208 with error -110
    [ 631.325350] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1004 with error -110

    [ 640.707935] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 640.834437] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    0
    [ 643.994828] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.118812] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.242358] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.370825] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.494915] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.626371] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.753384] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.878444] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x1000 with error -110
    [ 644.886828] ieee80211 phy0: rt2800_wait_csr_ready: Error - Unstable hardware
    [ 645.002431] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x07 failed for offset 0x7010 with error -110
    [ 645.114446] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x7010 with error -110
    [ 645.227491] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0404 with error -110
    Last edited by maiki; 2017-12-02 at 08:52. Reason: Merge posts

  6. #6
    Join Date
    2018-Mar
    Posts
    1
    Hello, I am having the same problem...were you able to fix this?

  7. #7
    Join Date
    2016-Dec
    Posts
    218
    Have you tried setting to USB 3.0?

Similar Threads

  1. Ralink RT2870/3070 connects to VMware but doesn't find networks!
    By realist-atte3n in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-08-18, 14:38
  2. Kali detects USB wireless adapter, but no wireless networks shown
    By reifi in forum TroubleShooting Archive
    Replies: 13
    Last Post: 2017-04-26, 11:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •