Results 1 to 3 of 3

Thread: Segmentation fault almost all basic command and cannot open anything

  1. #1
    Junior Member
    Join Date
    Dec 2017
    Posts
    2

    Segmentation fault almost all basic command and cannot open anything

    Hello, i am new here.

    Just note:
    - i install kali linux alongside windows 7, UEFI (Windwos Boot Manager).
    - Partition structure : sda5 ( /boot ), sda6 ( / ), sda7 ( /home ), sda8 ( swap area )
    - Install GRUB boot loader on sda5

    I want install: apt apache2 mysql-server mysql-client php5 phpmyadmin.
    after apache2 installation completed, mysql-server cannot be installed because not installation candidate.
    so i add another repository, i search on google then i get one (sana repository).

    When i try installing mysql-server again, i got an error

    Code:
    The following packages have unmet dependencies:
     gstreamer1.0-plugins-base : Breaks: gstreamer1.0-plugins-bad (< 1.11.90) but 1.6.2-1 is to be installed
     libgstreamer-plugins-base1.0-0 : Breaks: gstreamer1.0-plugins-bad (< 1.7.1) but 1.6.2-1 is to be installed
     libgstreamer1.0-0 : Breaks: gstreamer1.0-plugins-bad (< 1.11.1) but 1.6.2-1 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    I think i must install gstreamer1.0-plugins-bad, there is no plugins-base. So, i install it (and it is really bad).
    A moment it look like normal installation until this:

    Code:
    Get:150 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main i386 openmpi-common all 2.1.1-7 [154 kB]                                                  
    Get:151 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main i386 openmpi-bin i386 2.1.1-7 [189 kB]    
    Get:152 http://ftp.yzu.edu.tw/Linux/kali kali-rolling/main i386 proj-bin i386 4.9.3-2 [60.8 kB]                                                      
    Fetched 136 MB in 24min 44s (91.6 kB/s)                                                                                                              
    Reading changelogs... Done
    fontconfig (2.12.3-0.2) unstable; urgency=medium
    
      Starting with version 2.12, fontconfig is using "Slight" (hintslight) as
      automatic hinting style. This might change the rendering of the fonts.
    
      If you want the to restore the old hinting, run "dpkg-reconfigure
      fontconfig-config" and select "Full" as hinting style.
    
     -- Laurent Bigonville <bigon@debian.org>  Tue, 04 Jul 2017 21:10:57 +0200
    
    apt-listchanges: Mailing root: apt-listchanges: news for root
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 299327 files and directories currently installed.)
    Preparing to unpack .../libc-l10n_2.25-2_all.deb ...
    Unpacking libc-l10n (2.25-2) over (2.21-6) ...
    Preparing to unpack .../locales_2.25-2_all.deb ...
    Unpacking locales (2.25-2) over (2.21-6) ...
    Preparing to unpack .../locales-all_2.25-2_i386.deb ...
    Unpacking locales-all (2.25-2) over (2.21-6) ...
    Preparing to unpack .../archives/libc6_2.25-2_i386.deb ...
    Checking for services that may need to be restarted...
    Checking init scripts...
    Unpacking libc6:i386 (2.25-2) over (2.21-6) ...
    Setting up libc6:i386 (2.25-2) ...
    Installing new version of config file /etc/ld.so.conf.d/i386-linux-gnu.conf ...
    dpkg: error processing package libc6:i386 (--configure):
     subprocess installed post-installation script was killed by signal (Segmentation fault)
    Errors were encountered while processing:
     libc6:i386
    Segmentation fault
    Segmentation fault
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    E: Problem executing scripts DPkg::Post-Invoke '[ ! -x /usr/share/kali-menu/update-kali-menu ] || /usr/share/kali-menu/update-kali-menu wait_dpkg'
    E: Sub-process returned an error code
    when i run basic linux command like `ls`, and the others will return segmentation fault.
    this another error when i try install mysql-server again:
    Code:
    /etc# apt-get install mysql-server mysql-client --fix-broken --fix-missing
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libc-bin : Depends: libc6 (< 2.22) but 2.25-2 is to be installed
     libc-dev-bin : Depends: libc6 (< 2.22) but 2.25-2 is to be installed
     libc6-dbg : Depends: libc6 (= 2.21-6) but 2.25-2 is to be installed
     libc6-dev : Depends: libc6 (= 2.21-6) but 2.25-2 is to be installed
     libc6-i686 : PreDepends: libc6 (= 2.21-6) but 2.25-2 is to be installed
     locales : Depends: libc-bin (> 2.25) but 2.21-6 is to be installed
     mysql-client : Depends: mysql-client-5.5 but it is not going to be installed
     mysql-server : Depends: mysql-server-5.5 but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    i run apt-get -f install
    Code:
    apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following additional packages will be installed:
      binutils binutils-common binutils-i686-linux-gnu libbinutils libc-bin libc-dev-bin libc6-dbg libc6-dev linux-libc-dev
    Suggested packages:
      binutils-doc glibc-doc
    The following packages will be REMOVED:
      libc6-i686
    The following NEW packages will be installed:
      binutils-common binutils-i686-linux-gnu libbinutils
    The following packages will be upgraded:
      binutils libc-bin libc-dev-bin libc6-dbg libc6-dev linux-libc-dev
    6 upgraded, 3 newly installed, 1 to remove and 2085 not upgraded.
    4 not fully installed or removed.
    Segmentation fault
    before i posting this, i have reinstalling linux 3 time. And the second installation have same problem (segmentation fault) like this and it will refer to kernel error after rebooting.
    Code:
    Kernel panic - not syncing: Attempted to kill init!
    bla.. bla.. bla..
    Sorry for less information, i am spend a day around this problem, it's very tiring.

  2. #2
    Senior Member
    Join Date
    Dec 2016
    Posts
    127
    Sana hasn't been supported in more than a year or 2. So, you want to install 2017.3.

    In any case, do a memory check of your system (eg: use Windows Memory Diagnostic from UBCD).

  3. #3
    Junior Member
    Join Date
    Dec 2017
    Posts
    2
    Thanks for the information that sana no longer supported.

    I currently use kali-rolling.
    After all running normally, i meet this error again when installing apt-transport-https

    I think i know the problem is installing "libc6:i386", see the progress after my repository.

    This is my repository:
    Code:
    # deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot i386 LIVE/INSTALL $
    
    # deb cdrom:[Debian GNU/Linux 7.0 _Kali_ - Official Snapshot i386 LIVE/INSTALL $
    
    ## Security updates
    deb http://http.kali.org/ /kali main contrib non-free
    deb http://http.kali.org/ /wheezy main contrib non-free
    deb http://http.kali.org/kali kali-dev main contrib non-free
    deb http://http.kali.org/kali kali-dev main/debian-installer
    deb-src http://http.kali.org/kali kali-dev main contrib non-free
    deb http://http.kali.org/kali kali main contrib non-free
    deb http://http.kali.org/kali kali main/debian-installer
    deb-src http://http.kali.org/kali kali main contrib non-free
    deb http://security.kali.org/kali-security kali/updates main contrib non-free
    deb-src http://security.kali.org/kali-security kali/updates main contrib non-fr$
    running the installation:
    root@kali~/apt-get install apt-transport-https

    Code:
    The following additional packages will be installed:
      apt apt-utils binutils binutils-common binutils-i686-linux-gnu libapt-pkg5.0 libbinutils libc-bin libc-dev-bin libc-l10n libc6
      libc6-dbg libc6-dev libgnutls30 libidn2-0 libtasn1-6 libunistring2 linux-libc-dev locales locales-all
    Suggested packages:
      apt-doc aptitude | synaptic | wajig binutils-doc glibc-doc gnutls-bin
    The following packages will be REMOVED:
      libc6-i686
    The following NEW packages will be installed:
      apt-transport-https binutils-common binutils-i686-linux-gnu libbinutils libgnutls30 libidn2-0 libunistring2
    The following packages will be upgraded:
      apt apt-utils binutils libapt-pkg5.0 libc-bin libc-dev-bin libc-l10n libc6 libc6-dbg libc6-dev libtasn1-6 linux-libc-dev locales
      locales-all
    
    /*Get ...
     *Get ...
     */
    
    Get:21 http://ftp.yzu.edu.tw/Linux/kali kali-dev/main i386 apt-transport-https all 1.6~alpha5 [143 kB]                                
    Fetched 40.6 MB in 6min 0s (113 kB/s)                                                                                                 
    Reading changelogs... Done
    apt (1.6~alpha1) unstable; urgency=medium
    
      All methods provided by apt except for cdrom, gpgv, and rsh now
      use seccomp-BPF sandboxing to restrict the list of allowed system
      calls, and trap all others with a SIGSYS signal. Three options
      can be used to configure this further:
    
        APT::Sandbox::Seccomp is a boolean to turn it on/off
        APT::Sandbox::Seccomp::Trap is a list of names of more syscalls to trap
        APT::Sandbox::Seccomp::Allow is a list of names of more syscalls to allow
    
      Also, sandboxing is now enabled for the mirror method.
    
     -- Julian Andres Klode   Mon, 23 Oct 2017 01:58:18 +0200
    
    apt (1.5~beta1) unstable; urgency=medium
    
      [ New HTTPS method ]
      The default http method now supports HTTPS itself, including encrypted proxies
      and connecting to HTTPS sites via HTTPS proxies; and the apt-transport-https
      package only provides a "curl+https" method now as a fallback, but will be
      removed shortly. If TLS support is unwanted, it can be disabled overall by
      setting the option Acquire::AllowTLS to "false".
    
      As for backwards compatibility, the options IssuerCert and SslForceVersion
      are not supported anymore, and any specified certificate files must in the
      PEM format (curl might have allowed DER files as well).
    
      [ Changes to unauthenticated repositories ]
      The security exception for apt-get to only raise warnings if it encounters
      unauthenticated repositories in the "update" command is gone now, so that it
      will raise errors just like apt and all other apt-based front-ends do since
      at least apt version 1.3.
    
    apt-listchanges: Mailing root: apt-listchanges: news for kali
    Preconfiguring packages ...
    (Reading database ... 311473 files and directories currently installed.)
    Preparing to unpack .../libc-l10n_2.25-2_all.deb ...
    Unpacking libc-l10n (2.25-2) over (2.21-6) ...
    Preparing to unpack .../locales_2.25-2_all.deb ...
    Unpacking locales (2.25-2) over (2.21-6) ...
    Preparing to unpack .../locales-all_2.25-2_i386.deb ...
    Unpacking locales-all (2.25-2) over (2.21-6) ...
    Preparing to unpack .../archives/libc6_2.25-2_i386.deb ...
    Checking for services that may need to be restarted...
    Checking init scripts...
    Unpacking libc6:i386 (2.25-2) over (2.21-6) ...
    Setting up libc6:i386 (2.25-2) ... 
    Installing new version of config file /etc/ld.so.conf.d/i386-linux-gnu.conf ...
    dpkg: error processing package libc6:i386 (--configure):
     subprocess installed post-installation script was killed by signal (Segmentation fault)
    Errors were encountered while processing:
     libc6:i386
    Segmentation fault
    Segmentation fault
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    E: Problem executing scripts DPkg::Post-Invoke '[ ! -x /usr/share/kali-menu/update-kali-menu ] || /usr/share/kali-menu/update-kali-menu wait_dpkg'
    E: Sub-process returned an error code
    Just for my personal note, and maybe other new users know:
    First, i don't know that ubuntu is not like kali, you must install LAMP manually in ubuntu, because when installing kali linux, there is including apache2 and mysql and for phpmyadmin must update with new repository.
    If you understand how to use mysql for manage database, maybe you don't need phpmyadmin (more easy to used because of the GUI).

    Linux is so great, when this error appear, all programs that has been run before still can be used. But, when it closed, you cannot open again.
    After reboot, you cannot use kali linux anymore.

    Ah, i forget @Mister_X
    In any case, do a memory check of your system (eg: use Windows Memory Diagnostic from UBCD).
    Is the problem can refer to my memory, or just the package that not compatible with my system?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •