Results 1 to 9 of 9

Thread: No Wireless Extensions

  1. #1
    Join Date
    2016-Sep
    Posts
    11

    No Wireless Extensions

    I am trying to test out Airmon-ng and Aircrack-ng when I was trying to make sure my wireless adapter was configured.

    I am running Kali Linux on MacBook Pro through VMWare Fusion.

    I ran ifconfig and noticed my wireless adapter was not coming up.

    ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
    inet 192.168.2.23 netmask 255.255.255.0 broadcast 192.168.2.255
    inet6 fe80::20c:29ff:fe91:ef41 prefixlen 64 scopeid 0x20<link>
    ether 00:0c:29:91:ef:41 txqueuelen 1000 (Ethernet)
    RX packets 22190 bytes 33248713 (31.7 MiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 6077 bytes 408424 (398.8 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
    inet 127.0.0.1 netmask 255.0.0.0
    inet6 ::1 prefixlen 128 scopeid 0x10<host>
    loop txqueuelen 1000 (Local Loopback)
    RX packets 20 bytes 1116 (1.0 KiB)
    RX errors 0 dropped 0 overruns 0 frame 0
    TX packets 20 bytes 1116 (1.0 KiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0


    I also ran iwconfig

    iwconfig
    eth0 no wireless extensions.

    lo no wireless extensions.


    My adapter is configured in the VMWare Fusion System Settings and I can get out to the internet. I can ping 8.8.8.8

    ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=5.69 ms
    64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=8.89 ms
    64 bytes from 8.8.8.8: icmp_seq=3 ttl=56 time=5.67 ms
    64 bytes from 8.8.8.8: icmp_seq=4 ttl=56 time=7.96 ms
    64 bytes from 8.8.8.8: icmp_seq=5 ttl=56 time=8.56 ms
    64 bytes from 8.8.8.8: icmp_seq=6 ttl=56 time=8.19 ms


    I would love help to resolve this.

    Thank you,

  2. #2
    Join Date
    2016-Dec
    Posts
    372
    The wireless card, when using virtualization, must be USB. It cannot see internal card.

  3. #3
    Join Date
    2016-Sep
    Posts
    11
    Thanks Mister X for letting me know. That seems to be an issue that I would assume VMWare would fix.

  4. #4
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Quote Originally Posted by whitedragon21 View Post
    Thanks Mister X for letting me know. That seems to be an issue that I would assume VMWare would fix.
    They won't. You have to configure VMWare to work with your wifi adapter.

  5. #5
    Join Date
    2016-Sep
    Posts
    11
    Quote Originally Posted by _defalt View Post
    They won't. You have to configure VMWare to work with your wifi adapter.
    ok sorry I am receiving mixed answers. Does VMWare and Kali Linux recongize your internal wireless adapter on a MacBook Pro? As I mentioned above. The adapter appears to be configured in the Settings, I can ping out but the ifconfig and iwconfig does not see it.

    How do I resolve this if VMWare and Kali does use the internal wireless adapter on a MacBook Pro

  6. #6
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    799
    If you're doing wireless work from a virtual machine, you'll need a compatible USB wi-fi card. Good wi-fi cards cost $50 U.S. Dollars or less. It will save you a lot of time and aggravation.

  7. #7
    Join Date
    2016-Sep
    Posts
    11
    Hi All,

    I wanted to provide an update on this ticket. I purchased an Alph AWUS036AC Wi-Fi adapter since I say that it might be one of the better ones. I am running Kali Linux through VMWare Fusion on a MacBook Pro and I have had nothing but issues trying to get it to work.

    Trying to find a driver that works has been an issue. I finally found on https://www.kali.org/news/kali-linux-20171-release/ this actually worked on installing. The other Github drivers I found for some reason I couldn't get the "Make" command to run. It kept running into errors.

    I have been back and forth with Alfa support but for some reason we just can't get the Wi-Fi- adapter to recognize. Which was strange because in the preferences I have the network set to Wi-Fi, I have the RealTek device connectect but for some reason I can't choose Wi-Fi on the drop down see here


    2017-12-19_1002.jpg


    I would love help with this. I have been working on this for over a week now.

    Thx,

  8. #8
    Join Date
    2017-Dec
    Posts
    1
    First off, what model MBP do you have? It may be capable of running dual boot Kali. This is also a cost-effective method since Kali Linux should be able to detect the card on your MBP, as it has for me. There's only one issue and that's if you're trying to do pen testing..which is another topic.

  9. #9
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    209
    Check to see if your vm-machine needs a add-on pack to configure usb adapters. Sometime on vrtualmachine you need to also download, addon pack for various options. This can be found were you downloadef vmachine sometimes downpage of lnk.

Similar Threads

  1. Kali in Virtualbox no wireless extensions but Wifi working
    By Dudley in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-09-16, 02:51
  2. No Wireless Extensions
    By parad0x in forum General Archive
    Replies: 2
    Last Post: 2015-12-30, 10:39
  3. How to use extensions
    By Wolve in forum General Archive
    Replies: 3
    Last Post: 2013-09-19, 09:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •