I'am not able to install full version of kali on raspberry! I tried do to this 4 times already, and always get a serious problem. Usually system was unable to unpack or create fille.

What i did after first boot:
1.apt-get update.
2.apt-get install gparted -> resize memory (I'am using 16gb sd card).
3.apt-get upgrade / apt-get install kali-linux-full (i tried it in different order, errors on both).

Any of the basic repair installation commands that i googled doesn't work.

At this point when the upgrade or installation is processing after few minutes I'am getting different errors, about creating/unpacking file etc. Also usually terminal stops working, and don't recognizes commands, once even desktop changed color.

I watched many tuts on yt, and it seems like I'am doing everything fine.

What i investigated yesterday, was that the probably files in the path /usr/lib/local/ are broken and unable to read. At this point instalation is interrupted. Usualy can't create new file or delete one here. I can't even read any subfolder in this path, because it retrun: Cannot read file. Bad message.