Results 1 to 6 of 6

Thread: x11vnc is disconnecting kali-pi

  1. #1
    Junior Member
    Join Date
    Nov 2017
    Posts
    12

    x11vnc is disconnecting kali-pi

    I have kali pi installed on my pi3
    I could not get vncserver to work - i only go a grey screen so i am using x11vnc.
    The problem is that it keeps disconnecting after some time (5-10 minutes).
    when it happens i cannot reconnect - i get: "The connection was refused by the computer".
    i see this message when it crashes
    x11vnc *** stack smashing detected ***: x11vnc terminated
    what can i do?

    i am using x11vnc since i could not use vncserver.
    when i was connecting to vncserver i got grey screen with red X.

  2. #2
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    166
    You better ditch x11vnc and go back to tightvnc.
    Here's how to fix the grey screen:

    Code:
    wget -O ~/.vnc/xstartup https://raw.githubusercontent.com/Re4son/RPi-Tweaks/master/vncservice/xstartup

    I've just done it and it works like a charm

    Hope that helps.
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  3. #3
    Junior Member
    Join Date
    Nov 2017
    Posts
    12
    is this for kali linux on pi? of for the original pi installation?

  4. #4
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    166
    Kali on any pi
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  5. #5
    Junior Member
    Join Date
    Nov 2017
    Posts
    12
    works great thank you!!!
    been struggling with his for days!

  6. #6
    Junior Member
    Join Date
    Nov 2017
    Posts
    12
    Quote Originally Posted by re4son View Post
    You better ditch x11vnc and go back to tightvnc.
    Here's how to fix the grey screen:

    Code:
    wget -O ~/.vnc/xstartup https://raw.githubusercontent.com/Re4son/RPi-Tweaks/master/vncservice/xstartup

    I've just done it and it works like a charm

    Hope that helps.
    As i wrote it helps very much but i sometimes get this error:
    Xlib: extension "XInputExtension" missing on display ":1.0".
    & also:
    Xlib: extension "RANDR" missing on display ":1.0".

    what can i do? It prevent some application from starting.
    Last edited by janjan; 2017-12-18 at 09:47 PM. Reason: adding data

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •