Results 1 to 2 of 2

Thread: Having trouble installing Firefox on NetHunter - Any help would be appreciated.

  1. #1
    Join Date
    2017-Jan
    Posts
    23

    Having trouble installing Firefox on NetHunter - Any help would be appreciated.

    Hi.

    I flashed a recent nightly build of LineagOS 14.1 (11132017 bacon) + Nethunter (Kali Linux Rolling 3.4.113-lighting-kernel -vv38 ARMV7l). Connect using VNC server 127.0.0.1(5901) After successful install/configure (Full-Kali-Linux build) went to launched Web Browser.
    Web Browser Message “ Alert! Unable to connect to remote Host”

    Searched installed apps, no Web Browser installed.
    Install firefox Iceweasel, received message”ument dependencies Depends firefox-esr broken packages”
    Install Firefox-esr received message”ument dependencies Depends libhunspell-1.3.0, libjsoncpp0 broken packages”.

    Tried apt-get update –fix-missing.
    Went to Synaptic packages to install, getting the same results.
    So I have no Web browser available.

    (Q)
    Are there libhunspell-1.3.0, libjsoncpp0 packages in another repo to replace these broken versions?
    Is there an alternate Firefox package (ARM/AMRHF) supporting Android NetHunter I can install?
    I read Distro “Debian Jessie” has Iceweasel Firefox, Is this a good option?

    Have only used Linux for 3 months, so excuse my newbie questions.

    Thanks.
    /etc/apt/sources.list
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src http://http.kali.org/kali kali-rolling main contrib non-free
    deb http://security.debian.org/debian-security wheezy/updates main

  2. #2
    Join Date
    2017-Jan
    Posts
    23
    This is the OP.
    Couldn't fix the firefox libhunspell-1.3.0, libjsoncpp0 broken packages.
    Ended up getting Firefox-Esr v52 from Debian jessie repo.
    Did:
    1. Added line "deb http://security.debian.org/ jessie/updates main" in /etc/apt/sources.list.d/.
    2. $ apt-get update
    3. $ apt-get install firefox-esr.

Similar Threads

  1. Trouble installing nethunter on nexus 9 tablet
    By almandin in forum Installing NetHunter
    Replies: 0
    Last Post: 2017-11-04, 18:28
  2. TL-WN722N is plug and play? Not for me. Any help appreciated.
    By toast_ghost in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2015-10-07, 13:57
  3. Easy way to encrypt Home directory? Help is appreciated!
    By FinancialWiz in forum General Archive
    Replies: 0
    Last Post: 2014-07-12, 22:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •