Results 1 to 3 of 3

Thread: How to find rtl8821au drivers for Kali

  1. #1
    Join Date

    How to find rtl8821au drivers for Kali

    I was wondering how to find the driver for the Meross AC600, that require the Realtek rtl8821au driver.
    The included drivers do not compile.
    Any other git hub repository for the rtl8821au do not compile.
    Any help?

  2. #2
    Join Date
    Somewhere in the hell
    I thiink this github respo may work :

    May be Kali's respo also work as it uses the captioned respo as main stream :

    apt install realtek-rtl88xxau-dkms

    If it does not work, please run the following command :


    to get the hardware id and add below the line 199 of and then recompile it.

    Good luck!
    Last edited by samiux; 2017-12-25 at 10:01.
    While you do not know attack, how can you know about defense? (未知攻,焉知防?)
    Think like a criminal and act as a professional.
    Not only Try Harder but also Try Smarter!

  3. #3
    Join Date
    The Kali respo, realtek-rtl88xxau-dkms, covers the rtl8812-rtl8814 drivers, not the rtl8821. And this is confirmed by the fact that the usb wireless is not recognized.
    The is the 12, and not the 21, and not compile (or I'm not able to make it compile, I can show the errors).

    Update 1:
    So, with the commnd lsusb I've spotted the usb device
    Bus 002 Device 002: ID 8087:8000 Intel Corp.
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:8008 Intel Corp.
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 002: ID 0781:5583 SanDisk Corp.
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 005: ID 04f2:b3ed Chicony Electronics Co., Ltd
    Bus 003 Device 004: ID 138a:003f Validity Sensors, Inc. VFS495 Fingerprint Reader
    Bus 003 Device 008: ID 0bda:a811 Realtek Semiconductor Corp.
    Bus 003 Device 007: ID 8087:07dc Intel Corp.
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    It should be the Realtek one line.
    I've modified the usb_intf.c accordingly, adding the line

    {USB_DEVICE(0x0bda, 0xa811), .driver_info = RTL8821}, /* Meross AC600 */

    and I've recompiled successfully.
    After the reboot, I've sent the dmesg command and I see:

    [ 87.612786] usb 3-10: USB disconnect, device number 6
    [ 89.379497] usb 3-4: new high-speed USB device number 8 using xhci_hcd
    [ 89.527918] usb 3-4: New USB device found, idVendor=0bda, idProduct=a811
    [ 89.527922] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 89.527925] usb 3-4: Product: 802.11ac WLAN Adapter
    [ 89.527927] usb 3-4: Manufacturer: Realtek
    [ 89.527929] usb 3-4: SerialNumber: 00e04c000001
    [ 89.544038] 8812au: Unknown symbol __vfs_read (err 0)
    [ 394.618883] usb 3-2: USB disconnect, device number 2

    So everthing seems ok. But the USB wireless adapter is still not visible.
    Thanks for the help.

    Update 2:
    I've been able to modify the code of the realtek-rtl88xxau-dkms file as from your instructions, but the wireless adapter won't start.
    So I worked with the software provided by the vendor, and I've been able to compile it. Now the usb adapter starts, and is able to make the internet working. The ifconfig command returns:

    wlan1: flags=67<UP,BROADCAST,RUNNING> mtu 1500
    inet netmask broadcast
    inet6 fe80::bfa:668:85b4:ef27 prefixlen 64 scopeid 0x20<link>
    ether 16:88:11:c3:74:65 txqueuelen 1000 (Ethernet)
    RX packets 24301 bytes 237354385 (226.3 MiB)
    RX errors 0 dropped 3278 overruns 0 frame 0
    TX packets 19409 bytes 60340535 (57.5 MiB)
    TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

    but airmon-ng returns PHY null

    null wlan1 ?????? Realtek Semiconductor Corp.
    Last edited by maiki; 2017-12-26 at 09:43. Reason: Merge posts

Similar Threads

  1. CD install dialog can't find CD-ROM drivers...?
    By davebit in forum Installing Archive
    Replies: 0
    Last Post: 2016-01-30, 15:41
  2. Replies: 9
    Last Post: 2014-12-29, 16:14
  3. Nvidia Drivers for Kali not working (conflicting drivers)?
    By in10se in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2014-09-25, 18:59
  4. Cannot find wireless drivers - Wireless is not working
    By discobiscuit in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-12-06, 15:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts