Results 1 to 3 of 3

Thread: msfconsole error Could not find rake-12.3.0

  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    6

    msfconsole error Could not find rake-12.3.0

    Kali rolling based on Kali 2017.3 on a Pi 3 that's been working and stopped after updating today. Tried removing metasploit and reinstalling it, same error:

    root@pi2222:/home/support# msfconsole
    Could not find rake-12.3.0 in any of the sources
    Run `bundle install` to install missing gems.

    Is this an arm specific package issue or more general across Kali?

  2. #2
    Senior Member
    Join Date
    Nov 2015
    Location
    Australia
    Posts
    156
    Definitely not normal.
    I've just grabbed a new image, ran a full-upgrade and started msfconsole without a hitch.

    Have there been any errors during your apt upgrade?
    I'd just give it a day and try another upgrade. Probably just a glitch in the matrix ;-)
    ----------------------------------------
    Check out "Sticky Fingers Kali-Pi":
    https://whitedome.com.au/kali-pi

    Now with mana-toolkit and more goodies!

  3. #3
    Junior Member
    Join Date
    Jan 2018
    Location
    /univers/plutonium
    Posts
    27
    i do not understand what you want to say
    but if error on metasploit
    and still need it ,try downgrade metasploit or 2017.3 to 2017.2 using
    "sudo dpkg --configure -a"
    or not want to do this try
    "apt-get install metasploit"
    not work try
    "apt-get update && apt-get upgrade"
    then try to
    "apt-get install metasploit"
    hope work

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •