Results 1 to 4 of 4

Thread: Specific packages fail

  1. #1
    Junior Member
    Join Date
    Dec 2017
    Posts
    6

    Specific packages fail

    Hi Kali users!

    I'm having a weird issue where only a handful of packages are failing to update. I have been looking to solve this problem for about 2 weeks now, but I could not find any solution, and the issue is definitely not a temporary service shortage. All the other packages I've tried downloading work fine except these

    Code:
    E: Failed to fetch http://http.kali.org/kali/pool/main/r/ruby-librex/ruby-librex_0.0.68-0kali1+build1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/b/beef-xss/beef-xss_0.4.7.0-0kali4_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/u/unicorn-magic/unicorn-magic_2.6-0kali2_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/e/ettercap/ettercap-common_0.8.2-10_amd64.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/a/armitage/armitage_20150812-1kali2_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/c/cisco-global-exploiter/cisco-global-exploiter_13-1kali3_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/c/clusterd/clusterd_0.5-0kali2_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/c/cymothoa/cymothoa_1-beta-1kali1_amd64.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/d/davtest/davtest_1.0-1kali3_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/d/dbd/dbd_1.50-1kali2_amd64.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/f/fimap/fimap_1.00-0kali2_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/f/framework2/framework2_2.0-1kali0_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/g/golismero/golismero_2.0-beta6+git20150114-0kali1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/k/keimpx/keimpx_0.3+git20150318-0kali3_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/l/laudanum/laudanum_1.0+r36-0kali1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/m/mimikatz/mimikatz_2.1.1-20171219-0kali1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/n/nishang/nishang_0.7.6-0kali1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/p/powersploit/powersploit_2.2-1kali1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/r/responder/responder_2.3.3.9-0kali1_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/s/sbd/sbd_1.37-1kali1_amd64.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/s/set/set_7.7.4-0kali2_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/s/sqlninja/sqlninja_0.2.6-r1-1kali0_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/u/u3-pwn/u3-pwn_2.0-1kali3_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/non-free/w/wce/wce_1.42-beta-0kali0_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/main/w/webshells/webshells_1.1-0kali0_all.deb  Connection failed
    E: Failed to fetch http://http.kali.org/kali/pool/non-free/w/windows-binaries/windows-binaries_0.6.1_all.deb  Connection failed
    I'm not sure if this affects other packages as well

    My sources.list looks correct as per the official documentation:

    Code:
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    deb-src http://http.kali.org/kali kali-rolling main contrib non-free
    You can try the URLs for these packages yourself from the browser, for example:


    http://http.kali.org/kali/pool/main/r/ruby-librex/ruby-librex_0.0.68-0kali1+build1_all.deb

    http://http.kali.org/kali/pool/main/...0kali4_all.deb

    However any other package will work, for example:

    http://http.kali.org/kali/pool/main/...g0-3_amd64.deb
    http://http.kali.org/kali/pool/main/....3-1_amd64.deb

    Thanks in advance for any help and happy 2018!

  2. #2
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    705
    Have you tried a different mirror? The one you default to may be broken.

  3. #3
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    845
    It's a connection issue.

    You don't need the second entry in your sources.list. deb-src is used by those who want to compile and install packages from their source. deb-src downloads source code of packages. Comment that line if you don't compile packages yourself.

  4. #4
    Senior Member
    Join Date
    Apr 2013
    Location
    in a computer
    Posts
    705
    Thanks for the correction, _defalt I missed the pattern in the error messages.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •