Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Not able to uprade from kernel 4.12

  1. #11
    Member
    Join Date
    Dec 2016
    Posts
    79
    Quote Originally Posted by mictadlo View Post
    I changed it to wheezy and I can still only choose 4.12. What did I miss?

    # ls /lib/modules/
    4.12.0-kali1-amd64 4.12.0-kali2-amd64 4.13.0-kali1-amd64 4.14.0-kali1-amd64 4.14.0-kali3-amd64 4.14.0-kali3-rt-amd64

    # ls /boot/
    config-4.12.0-kali1-amd64 grub initrd.img-4.12.0-kali1-amd64 System.map-4.12.0-kali1-amd64 vmlinuz-4.12.0-kali1-amd64
    Did you rerun a apt-get update && apt-get dust-upgrade? With the changes. Also with the extra repo sources like stated by re4son you could have broken you install.

  2. #12
    Junior Member
    Join Date
    Jan 2018
    Posts
    5
    The only thing which helped was to do `apt install linux-image-amd64`

  3. #13
    Senior Member
    Join Date
    Oct 2016
    Location
    /dev/sda
    Posts
    846
    Quote Originally Posted by mictadlo View Post
    The only thing which helped was to do `apt install linux-image-amd64`
    Atleast check what is there in /etc/apt/sources.list.d as told by re4son twice. Having extra and unofficial repositories will most likely break your filesystem in future.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •