Results 1 to 4 of 4

Thread: Help needed!! Maybe one of you can help with my Wireless Card Firmware/Driver

  1. #1
    Junior Member
    Join Date
    Jan 2018
    Posts
    3

    Angry Help needed!! Maybe one of you can help with my Wireless Card Firmware/Driver

    This is the error I'm getting wireless card works. I've been at this all night.


    root@kali:~# lspci -knn|grep -iA2 net
    02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
    Subsystem: ASUSTeK Computer Inc. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1043:200f]
    Kernel driver in use: r8169
    Kernel modules: r8169
    03:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
    Subsystem: AzureWave QCA9377 802.11ac Wireless Network Adapter [1a3b:2b31]
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci
    root@kali:~# dmesg|grep 'ath\|firmw'
    [ 10.767551] ath10k_pci 0000:03:00.0: enabling device (0000 -> 0002)
    [ 10.770206] ath10k_pci 0000:03:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
    [ 11.084732] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
    [ 11.084818] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
    [ 11.084856] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
    [ 11.084930] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
    [ 11.085503] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-6.bin (-2)
    [ 11.085589] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-6.bin failed with error -2
    [ 11.105031] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
    [ 11.105048] ath10k_pci 0000:03:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 1a3b:2b31
    [ 11.105053] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
    [ 11.106414] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
    [ 11.676852] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
    [ 11.680399] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
    [ 11.919605] i915 0000:00:02.0: firmware: direct-loading firmware i915/kbl_dmc_ver1_01.bin
    [ 11.921363] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_01.bin (v1.1)
    [ 12.163974] ath10k_pci 0000:03:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
    [ 12.167129] ath: EEPROM regdomain: 0x6a
    [ 12.167132] ath: EEPROM indicates we should expect a direct regpair map
    [ 12.167134] ath: Country alpha2 being used: 00
    [ 12.167136] ath: Regpair used: 0x6a
    [ 23.439082] r8169 0000:02:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-3.fw
    [40654.895951] (NULL device *): firmware: direct-loading firmware i915/kbl_dmc_ver1_01.bin
    [40674.071006] ath10k_pci 0000:03:00.0: failed to receive scan abortion completion: timed out
    [40674.071011] ath10k_pci 0000:03:00.0: failed to abort scan: -110
    [40679.190955] ath10k_pci 0000:03:00.0: failed to synchronize setup for vdev 0 restart 0: -110
    [40679.190958] ath10k_pci 0000:03:00.0: failed to start vdev 0 addr f0:03:8c:8f:1c:6d on freq 2412: -110
    [40679.601167] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601169] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    [40679.601171] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601172] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    [40679.601173] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601174] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    [40679.601176] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601177] ath10k_pc[ 10.767551] ath10k_pci 0000:03:00.0: enabling device (0000 -> 0002)
    [ 10.770206] ath10k_pci 0000:03:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
    [ 11.084732] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
    [ 11.084818] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
    [ 11.084856] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
    [ 11.084930] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
    [ 11.085503] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA9377/hw1.0/firmware-6.bin (-2)
    [ 11.085589] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-6.bin failed with error -2
    [ 11.105031] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
    [ 11.105048] ath10k_pci 0000:03:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 1a3b:2b31
    [ 11.105053] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
    [ 11.106414] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
    [ 11.676852] ath10k_pci 0000:03:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
    [ 11.680399] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
    [ 11.919605] i915 0000:00:02.0: firmware: direct-loading firmware i915/kbl_dmc_ver1_01.bin
    [ 11.921363] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_01.bin (v1.1)
    [ 12.163974] ath10k_pci 0000:03:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
    [ 12.167129] ath: EEPROM regdomain: 0x6a
    [ 12.167132] ath: EEPROM indicates we should expect a direct regpair map
    [ 12.167134] ath: Country alpha2 being used: 00
    [ 12.167136] ath: Regpair used: 0x6a
    [ 23.439082] r8169 0000:02:00.0: firmware: direct-loading firmware rtl_nic/rtl8168g-3.fw
    [40654.895951] (NULL device *): firmware: direct-loading firmware i915/kbl_dmc_ver1_01.bin
    [40674.071006] ath10k_pci 0000:03:00.0: failed to receive scan abortion completion: timed out
    [40674.071011] ath10k_pci 0000:03:00.0: failed to abort scan: -110
    [40679.190955] ath10k_pci 0000:03:00.0: failed to synchronize setup for vdev 0 restart 0: -110
    [40679.190958] ath10k_pci 0000:03:00.0: failed to start vdev 0 addr f0:03:8c:8f:1c:6d on freq 2412: -110
    [40679.601167] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601169] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    [40679.601171] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601172] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    [40679.601173] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601174] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    [40679.601176] ath10k_pci 0000:03:00.0: received scan bss chan event in an invalid scan state: idle (0)
    [40679.601177] ath10k_pci 0000:03:00.0: received scan foreign chan event in an invalidi 0000:03:00.0: received scan foreign chan event in an invalid scan state: idle (0)
    root@kali:~#
    Last edited by woodbine; 2018-01-13 at 11:22 PM. Reason: removed foul language

  2. #2
    Junior Member
    Join Date
    Jan 2018
    Posts
    3
    I was thinking of just pointing the wireless kernal and module to ath and i915 instead of ath10k_pci. Though I'm not sure if that would be the solution.

  3. #3
    Senior Member
    Join Date
    Dec 2016
    Posts
    135
    Do the firmware files mentioned in the log exist? If not, install the firmware. It should be either linux-firmware or firmware-atheros. Something like that. Search using apt-cache.

  4. #4
    Junior Member
    Join Date
    Jan 2018
    Posts
    3
    the file do not exist even is the firmware files that your guiding me to download i already checked both. I probably need to check the driver. ath10_pci file source.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •