Results 1 to 5 of 5

Thread: openvpn-gnome problem after kali upgrade

  1. #1
    Join Date
    2018-Jan
    Posts
    9

    openvpn-gnome problem after kali upgrade

    Hi. I have been using openvpn+gnome for quite a while with no problems, but after recent upgrade it doesn't work anymore.

    Openvpn itself is working fine. I can connect to VPN with:

    Code:
    $ sudo openvpn Arstotzka.ovpn
    ...so no problems with VPN provider.

    But, if I try to use gnome interface to connect to VPN it doesn't work, gnome just refuses to do anything. A few days ago before upgrade it was totally fine.

    /etc/NetworkManager/system-connections/ is populated with configurations, as /etc/openvpn/ with certificates.

    Code:
    $ uname -a
    Linux kali 4.14.0-kali3-amd64 #1 SMP Debian 4.14.13-1kali1 (2018-01-25) x86_64 GNU/Linux
    So any ideas?

    Thanks.

  2. #2
    Join Date
    2018-Jan
    Posts
    9
    Well, I'm not sure what happened but today it's working fine. Maybe because I've just reinstalled openvpn yesterday or maybe because of last kali upgrade.

  3. #3
    Join Date
    2018-Feb
    Posts
    1
    Mine is still having problems. Do you have any idea what fixed it?

  4. #4
    Join Date
    2018-Jan
    Posts
    9
    I'm not sure what I've done, but at the end I just reinstalled everything.

    You also can try to remove old connections from network-manager, just be sure not to delete important connections:
    Code:
    # rm -rf /etc/NetworkManager/system-connections/*
    Purge old openvpn config:
    Code:
    # rm -rf /etc/openvpn
    Delete and reinstall all packages:
    Code:
    # apt-get purge network-manager-openvpn network-manager-openvpn-gnome openvpn
    # apt-get install network-manager-openvpn network-manager-openvpn-gnome openvpn
    # service network-manager restart
    and try again to install your openvpn config from VPN provider.

  5. #5
    Join Date
    2017-Dec
    Posts
    5
    Anyone know how to fix this one?
    http://imgur.com/eH0UMrF
    http://imgur.com/dl2Q4iZ

Similar Threads

  1. GNOME Settings Menu Disappeared After Kali 2.0 AMD64 Upgrade on HDD
    By drag0n in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2016-10-07, 09:35
  2. Anyone else having issues with openvpn/openvpn-gnome now?
    By fonestar in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-06-05, 20:16
  3. kali openvpn connection problem
    By Fetalerror in forum General Archive
    Replies: 1
    Last Post: 2015-06-21, 19:57
  4. is it a good idea to manually upgrade to Gnome 3.8 or 3.10 ?
    By randvoo12 in forum General Archive
    Replies: 2
    Last Post: 2014-04-03, 19:12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •