I have for several weeks now tried to install my wifi dongle on my Kali linux in VMware, but have run into errors all the way. The wifi usb adapter I am using is Asus usb-ac51 which has mt7610u/RT2870 chipset. First I tried to download the driver from both Asus and Mediatek, but they both gave me several errors when using the make command. I found a driver on github which I managed to install, but it is still not working. It shows up in iwconfig, but not in ifconfig, and it does not allow me to use the ifconfig ra0 up command. For some reason it does not show as wlan0, but as ra0. I have tried close to all suggestions on all forums, but to no avail. I have updated my Linux to the newest kernel, and with the headers aswell. The kernel I am using is 4.14.0.

This is the error code I am getting when trying to use the make command on the driver:
cc1: some warnings being treated as errors
/usr/src/linux-headers-4.14.0-kali3-common/scripts/Makefile.build:319: recipe for target '/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../sta/sta_cfg.o' failed
make[4]: *** [/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../sta/sta_cfg.o] Error 1
/usr/src/linux-headers-4.14.0-kali3-common/Makefile:1525: recipe for target '_module_/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux' failed
make[3]: *** [_module_/root/Downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux] Error 2
Makefile:146: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.14.0-kali3-amd64'
Makefile:393: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2

Can someone come with some suggestions as to what I can do? I'm kinda stuck at this point