Results 1 to 7 of 7

Thread: How can I change the screen size

  1. #1
    Join Date
    2018-Feb
    Location
    Spain
    Posts
    1

    Unhappy How can I change the screen size

    My laptop have a 13 inch display with FullHD resolution so everything is so small. How can I increase the size of all items on screen without changing the resolution? Thanks

  2. #2
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    Settings>Devices>Displays

  3. #3
    Join Date
    2017-Nov
    Posts
    1
    I have the same question. Found that screen but it only lists 1152x864 as the only option.

    I'm running the 2018.1 Hyper-V image if that makes a difference.

    I have tried editing /etc/default/grub to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1280x720" but it doesn't work (but did in a previous install).

    Thanks

  4. #4
    Join Date
    2016-Jun
    Posts
    2
    Under settings ---> devices ---> display. There it should give you the option to change your resolution.

  5. #5
    Join Date
    2018-Apr
    Posts
    1
    Found the same issue on 2018.1. Remove "hyper-v_fb" from the line to make it: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=1280x720"

    Was able to change the res after this.

  6. #6
    Join Date
    2018-May
    Posts
    1
    These fixes didn't work for me at first as I had enabled the RemoteFX 3D Video Adapter in the Hyper-V settings for the VM. As another (since archived) thread noted, hyperv_fb was not running while the adapter was enabled, and neither "quiet splash video=hyperv_fb:1920x1080" or the variation with "hyperv_fb" omitted would work.

    Once I disabled the RemoteFX Adapter in the Hyper-V settings, I confirmed with lsmod that hyperv_fb was running, updated the grub file as described (using GRU
    B_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1920x1080") and the VM rebooted straight into 1920x1080 resolution.

  7. #7
    Join Date
    2018-Jun
    Posts
    1
    Hi all:
    I tried updating my resolution for the hyper-v in /etc/default/grub when i run the command sudo update-grub i get the following error
    /usr/sbin/grub-mkconfig: 2: /etc/default/grub: x: not found

    below is the grub file:

    # If you change this file, run 'update-grub' afterwards to update
    x /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1920x1080"
    GRUB_CMDLINE_LINUX=video=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

    many thanks

Similar Threads

  1. xrandr shows failure and only one size for Screen 0
    By tokmo in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2014-06-08, 08:54
  2. Replies: 1
    Last Post: 2013-09-18, 02:57
  3. Problems with screen size with nvidia driver
    By S00UL in forum General Archive
    Replies: 0
    Last Post: 2013-05-10, 02:17

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •