Results 1 to 4 of 4

Thread: Can't run wfuzz

  1. #1
    Join Date
    2014-Nov
    Posts
    10

    Can't run wfuzz

    After having viewed a video on how to use wfuzz to attack the MrRobot ova on vulnhub, I was going to give it a try.

    No luck:
    root@Kali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1# /usr/local/bin/wfuzz

    Warning: Pycurl is not compiled against Openssl. Wfuzz might not work correctly when fuzzing SSL sites. Check Wfuzz's documentation for more information.

    This directory is from these instructions:

    http://wfuzz.readthedocs.io/en/lates...he-source-code

    Here are the results of my trying to build it per the above instructions:
    root@daveKali:/home/dave/python-pycurl-openssl# sudo apt-get source python-pycurl
    Reading package lists... Done
    Picking 'pycurl' as source package instead of 'python-pycurl'
    NOTICE: 'pycurl' packaging is maintained in the 'Git' version control system at:
    https://anonscm.debian.org/git/pytho...ges/pycurl.git
    Please use:
    git clone https://anonscm.debian.org/git/pytho...ges/pycurl.git
    to retrieve the latest (possibly unreleased) updates to the package.
    Need to get 213 kB of source archives.
    Get:1 http://archive-7.kali.org/kali kali-rolling/main pycurl 7.43.0.1-0.1 (dsc) [2,181 B]
    Get:2 http://archive-7.kali.org/kali kali-rolling/main pycurl 7.43.0.1-0.1 (tar) [202 kB]
    Get:3 http://archive-7.kali.org/kali kali-rolling/main pycurl 7.43.0.1-0.1 (diff) [9,180 B]
    Fetched 213 kB in 1s (257 kB/s)
    dpkg-source: info: extracting pycurl in pycurl-7.43.0.1
    dpkg-source: info: unpacking pycurl_7.43.0.1.orig.tar.gz
    dpkg-source: info: unpacking pycurl_7.43.0.1-0.1.debian.tar.xz
    dpkg-source: info: applying 10_setup.py.patch
    dpkg-source: info: applying 20_build_doc_for_debian.patch
    dpkg-source: info: applying 30_debianize_tests.patch
    dpkg-source: info: applying 0004-Removed-privacy-breach-in-docs.patch
    W: Download is performed unsandboxed as root as file 'pycurl_7.43.0.1-0.1.dsc' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)
    root@daveKali:/home/dave/python-pycurl-openssl# ls
    pycurl-7.43.0.1 pycurl_7.43.0.1-0.1.debian.tar.xz pycurl_7.43.0.1-0.1.dsc pycurl_7.43.0.1.orig.tar.gz
    root@daveKali:/home/dave/python-pycurl-openssl# cd pycurl-7.43.0.1/
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1# ls
    AUTHORS COPYING-LGPL debian examples Makefile PKG-INFO README.rst requirements-dev-3.1.txt setup.py tests winbuild.py
    ChangeLog COPYING-MIT doc INSTALL.rst MANIFEST.in python RELEASE-NOTES.rst requirements-dev.txt src winbuild
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1# cd debian/
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1/debian# ls
    changelog compat control copyright patches python-pycurl-doc.doc-base rules source tests TODO watch
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1/debian# vi control
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1/debian# cd ..
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1# sudo dpkg-buildpackage -rfakeroot -b
    dpkg-buildpackage: warning: using a gain-root-command while being root
    dpkg-buildpackage: info: source package pycurl
    dpkg-buildpackage: info: source version 7.43.0.1-0.1
    dpkg-buildpackage: info: source distribution unstable
    dpkg-buildpackage: info: source changed by Iain R. Learmonth <irl@debian.org>
    dpkg-buildpackage: info: host architecture amd64
    dpkg-source --before-build pycurl-7.43.0.1
    dpkg-source: error: architecture any only allowed on its own (list for package python3-pycurl is 'any')
    dpkg-buildpackage: error: dpkg-source --before-build pycurl-7.43.0.1 subprocess returned exit status 255
    root@daveKali:/home/dave/python-pycurl-openssl/pycurl-7.43.0.1# /usr/local/bin/w
    wfencode wfpayload wfuzz wxfuzz

    So something is wrong, or I did something wrong.

    Thoughts?
    Thanks...

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    786
    I've seen that error using wfuzz before, and it's worked fine with me. Have you tried letting wfuzz run?

  3. #3
    Join Date
    2014-Nov
    Posts
    10
    I tried fuzzing a VulnHub image with WP installed. But I get the error about Pycurl. So I need to figure out how to get that fixed first.

    Any thoughts?

  4. #4
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    786
    So wfuzz throws the Pycurl error and then just stops?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •