Results 1 to 8 of 8

Thread: WiFi Module does not work

  1. #1
    Join Date
    2018-Feb
    Posts
    2

    WiFi Module does not work

    Hello everybody,

    I have an ASUS ROG Crosshair VI Extreme motherboard with integrated WiFi. The Module should be a Realtek RTL8822be (looked it up on Windows because Linux does not show any information about it). It is working properly (after driver install) on Windows 10 Pro but I can't get it to work on my Linux. Meanwhile I tried a lot but noting of success. The driver DVD just states in a text file "Note: Please update to the latest Linux Kernel for motherboard chipset and components support." The latest kernel should be ("uname -r") "4.14.0-kali3-amd64", installed is ("uname -v") "#1 SMP Debian 4.14.13-1kali1 (2018-01-25)", so this should not be a problem. https://wiki.debian.org/rtl819x#rtl8821ae gives some advice to install "firmware-realtek" which actually results in "firmware-realtek is already the latest version (20170823-1)".
    My USB-WiFi-Stick with a RTL8192CU Module works without any problems and the integrated LAN controller also works perfectly fine. I thought maybe it is a problem that I installed Linux using the WiFi Stick and now the drivers are interfering somehow but I could not find anything that confirms this thesis and this would be a bit stupid if you have to switch from one adapter to another e.g. because of hardware failure.
    I am not sure what else information you need, please let me know!

    Thank you for your solutions in advance!

    Best regards

    DaUlm

  2. #2
    Join Date
    2016-Dec
    Posts
    252
    What makes you say it doesn't work? Is there any interface when running ifconfig?

    Have you looked at the content of dmesg?

  3. #3
    Join Date
    2018-Feb
    Posts
    2
    Thanks for your response!
    ifconfig shows the following:
    Code:
    eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether 10:7b:44:90:2a:c7  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device memory 0xfe200000-fe21ffff  
    
    ham0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1404
            inet6 fe80::7879:ff:fe00:0  prefixlen 64  scopeid 0x20<link>
            ether 7a:79:00:00:00:00  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 15  bytes 1178 (1.1 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 96  bytes 7404 (7.2 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 96  bytes 7404 (7.2 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.2.102  netmask 255.255.255.0  broadcast 192.168.2.255
            inet6 2003:e1:735:3c39:7cae:81e0:da03:9368  prefixlen 64  scopeid 0x0<global>
            inet6 fe80::c6e9:84ff:fe1e:2cb9  prefixlen 64  scopeid 0x20<link>
            inet6 2003:e1:735:3c39:c6e9:84ff:fe1e:2cb9  prefixlen 64  scopeid 0x0<global>
            ether c4:e9:84:1e:2c:b9  txqueuelen 1000  (Ethernet)
            RX packets 12404  bytes 15749618 (15.0 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 7978  bytes 1169004 (1.1 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    You can see my Lan Port, a hamachi network and my wlan0 from the USB Stick are active but my internal card is not.

    The last 50 lines of dmesg show this:
    Code:
    [    7.643080] [drm] ib test on ring 8 succeeded
    [    7.689718] rtl8192cu: Board Type 0
    [    7.690842] rtl_usb: rx_max_size 15360, rx_urb_num 8, in_ep 1
    [    7.690896] rtl8192cu: Loading firmware rtlwifi/rtl8192cufw_TMSC.bin
    [    7.691612] usb 5-1: firmware: direct-loading firmware rtlwifi/rtl8192cufw_TMSC.bin
    [    7.693595] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
    [    7.693843] usbcore: registered new interface driver rtl8192cu
    [    8.156072] [drm] ib test on ring 9 succeeded
    [    8.156104] [drm] ib test on ring 10 succeeded
    [    8.156125] [drm] ib test on ring 11 succeeded
    [    8.157978] [drm] ib test on ring 12 succeeded
    [    8.158221] [drm] ib test on ring 13 succeeded
    [    8.236079] usblp 1-13:1.0: usblp4: USB Bidirectional printer dev 11 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0200
    [    8.236105] usbcore: registered new interface driver usblp
    [    8.316055] [drm] fb mappable at 0xE04B7000
    [    8.316056] [drm] vram apper at 0xE0000000
    [    8.316065] [drm] size 11059200
    [    8.316066] [drm] fb depth is 24
    [    8.316067] [drm]    pitch is 10240
    [    8.316135] fbcon: amdgpudrmfb (fb0) is primary device
    [    8.399636] tun: Universal TUN/TAP device driver, 1.6
    [    8.420671] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [    8.446458] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    [    8.449897] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [    8.453464] rtl8192cu: MAC auto ON okay!
    [    8.519818] Console: switching to colour frame buffer device 210x65
    [    8.652987] rtl8192cu: Tx queue select: 0x05
    [    8.656625] amdgpu 0000:29:00.0: fb0: amdgpudrmfb frame buffer device
    [    8.688613] amdgpu 0000:29:00.0: kfd not supported on this ASIC
    [    8.688624] [drm] Initialized amdgpu 3.19.0 20150101 for 0000:29:00.0 on minor 0
    [    9.714671] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [    9.720884] rtl8192cu: MAC auto ON okay!
    [    9.733314] rtl8192cu: Tx queue select: 0x05
    [   10.283919] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   10.342830] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   11.310418] rtl8192cu: MAC auto ON okay!
    [   11.323028] rtl8192cu: Tx queue select: 0x05
    [   11.873560] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [   12.888600] wlan0: authenticate with 60:e7:01:9d:9b:18
    [   12.911407] wlan0: send auth to 60:e7:01:9d:9b:18 (try 1/3)
    [   12.936356] wlan0: authenticated
    [   12.944253] wlan0: associate with 60:e7:01:9d:9b:18 (try 1/3)
    [   12.957232] wlan0: RX AssocResp from 60:e7:01:9d:9b:18 (capab=0x1411 status=0 aid=2)
    [   13.058736] wlan0: associated
    [   13.084792] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [   13.319578] usblp4: removed
    [   13.337728] usblp 1-13:1.0: usblp4: USB Bidirectional printer dev 11 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0200
    [   22.585987] rfkill: input handler disabled
    [   24.169979] ISO 9660 Extensions: Microsoft Joliet Level 3
    [   24.173023] ISOFS: changing to secondary root
    There is absolutely nothing about my internal WiFi Adapter.
    Interestingly inxi -Fn shows the Adapter (Card-2) but without any further specification:
    Code:
    Network:   Card-1: Intel I211 Gigabit Network Connection driver: igb
               IF: eth0 state: down mac: 10:7b:44:90:2a:c7
               Card-2: Realtek Device b822
               IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
               Card-3: Realtek RTL8192CU 802.11n WLAN Adapter
               IF: N/A state: N/A mac: N/A
    So the hardware is being detected but the sowftware seems to be missing. Since it should have come with the latest kernel I have no idea how to install or activate it now.
    Last edited by 1st_daulm; 2018-02-04 at 14:29.

  4. #4
    Join Date
    2013-Apr
    Posts
    163
    same problem with you , the hardware detected but the driver is not working , WIFI rtl8822be .

    07:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter

    i choose the github non-free driver for rtl8822be .

    but when i do make ,

    root@debian:~/rtlwifi-next# ls
    base.c btcoexist cam.h core.h debug.h efuse.h halmac LICENSE pci.c
    base.h cam.c core.c debug.c efuse.c firmware Kconfig Makefile pci.h
    root@debian:~/rtlwifi-next# make
    make -C /lib/modules/4.15.0-kali3-amd64/build M=/root/rtlwifi-next modules
    make[1]: *** /lib/modules/4.15.0-kali3-amd64/build: No such file or directory. Stop.
    Makefile:100: recipe for target 'all' failed
    make: *** [all] Error 2
    root@debian:~/rtlwifi-next#


    SHELL := /bin/sh
    CC = gcc
    KVER := $(shell uname -r)
    KSRC := /lib/modules/$(KVER)/build
    FIRMWAREDIR := /lib/firmware/
    PWD := $(shell pwd)
    CLR_MODULE_FILES := *.mod.c *.mod *.o .*.cmd *.ko *~ .tmp_versions* modules.order Module.symvers
    SYMBOL_FILE := Module.symvers
    # Handle the move of the entire rtlwifi tree
    ifneq ("","$(wildcard /lib/modules/$(KVER)/kernel/drivers/net/wireless/realtek)")
    MODDESTDIR := /lib/modules/$(KVER)/kernel/drivers/net/wireless/realtek/rtlwifi
    else
    MODDESTDIR := /lib/modules/$(KVER)/kernel/drivers/net/wireless/rtlwifi
    endif
    #Handle the compression option for modules in 3.18+
    ifneq ("","$(wildcard $(MODDESTDIR)/*.ko.gz)")
    COMPRESS_GZIP := y
    endif
    ifneq ("","$(wildcard $(MODDESTDIR)/*.ko.xz)")
    COMPRESS_XZ := y
    endif

    EXTRA_CFLAGS += -O2

    CONFIG_RTLWIFI=m
    CONFIG_RTLWIFI_PCI=m
    CONFIG_RTLWIFI_USB=m
    CONFIG_RTL8192C_COMMON=m
    CONFIG_RTLWIFI_DEBUG=y
    CONFIG_RTL8192CE=m
    CONFIG_RTL8192CU=m
    CONFIG_RTL8192SE=m
    CONFIG_RTL8192DE=m
    CONFIG_RTL8723AE=m
    CONFIG_RTL8723BE=m
    CONFIG_RTL8188EE=m
    CONFIG_RTLBTCOEXIST=m
    CONFIG_RTLHALMAC=m
    CONFIG_RTLPHYDM=m
    CONFIG_RTL8723_COMMON=m
    CONFIG_RTL8821AE=m
    CONFIG_RTL8822BE=m
    CONFIG_RTL8192EE=m

    export CONFIG_RTL8192C_COMMON CONFIG_RTL8192CE CONFIG_RTL8192CU CONFIG_RTL8192SE CONFIG_RTL8192DE CONFIG_RTL8192EE
    export CONFIG_RTL8723AE CONFIG_RTL8723BE CONFIG_RTL8723_COMMON
    export CONFIG_RTL8188EE CONFIG_RTL8821AE
    export CONFIG_RTLBTCOEXIST


    obj-$(CONFIG_RTLWIFI) += rtlwifi.o
    rtlwifi-objs := \
    base.o \
    cam.o \
    core.o \
    debug.o \
    efuse.o \
    ps.o \
    rc.o \
    regd.o \
    stats.o

    rtl8192c_common-objs += \

    obj-$(CONFIG_RTLWIFI_PCI) += rtl_pci.o
    rtl_pci-objs := pci.o

    obj-$(CONFIG_RTLWIFI_USB) += rtl_usb.o
    rtl_usb-objs := usb.o

    obj-$(CONFIG_RTL8192C_COMMON) += rtl8192c/
    obj-$(CONFIG_RTL8192CE) += rtl8192ce/
    obj-$(CONFIG_RTL8192CU) += rtl8192cu/
    obj-$(CONFIG_RTL8192SE) += rtl8192se/
    obj-$(CONFIG_RTL8192DE) += rtl8192de/
    obj-$(CONFIG_RTL8723AE) += rtl8723ae/
    obj-$(CONFIG_RTL8723BE) += rtl8723be/
    obj-$(CONFIG_RTL8188EE) += rtl8188ee/
    obj-$(CONFIG_RTLBTCOEXIST) += btcoexist/
    obj-$(CONFIG_RTLHALMAC) += halmac/
    obj-$(CONFIG_RTLPHYDM) += phydm/
    obj-$(CONFIG_RTL8723_COMMON) += rtl8723com/
    obj-$(CONFIG_RTL8821AE) += rtl8821ae/
    obj-$(CONFIG_RTL8822BE) += rtl8822be/
    obj-$(CONFIG_RTL8192EE) += rtl8192ee/

    ccflags-y += -D__CHECK_ENDIAN__
    #subdir-ccflags-y += -Werror
    ccflags-y += -DCONFIG_RTLWIFI_DEBUG
    subdir-ccflags-y += -DCONFIG_RTLWIFI_DEBUG

    ifeq ("$(KVER)", "3.14.35-031435-generic")
    ccflags-y += -D_ieee80211_is_robust_mgmt_frame=ieee80211_is_robu st_mgmt_frame
    subdir-ccflags-y += -D_ieee80211_is_robust_mgmt_frame=ieee80211_is_robu st_mgmt_frame
    endif

    CHECKFLAGS += -D__CHECK_ENDIAN__

    all:
    $(MAKE) -C $(KSRC) M=$(PWD) modules
    install: all
    ifeq (,$(wildcard ./backup_drivers.tar))
    @echo Making backups
    @tar cPf backup_drivers.tar $(MODDESTDIR)
    endif

    @mkdir -p $(MODDESTDIR)/btcoexist
    @mkdir -p $(MODDESTDIR)/halmac
    @mkdir -p $(MODDESTDIR)/phydm
    @mkdir -p $(MODDESTDIR)/rtl8188ee
    @mkdir -p $(MODDESTDIR)/rtl8192c
    @mkdir -p $(MODDESTDIR)/rtl8192ce
    @mkdir -p $(MODDESTDIR)/rtl8192cu
    @mkdir -p $(MODDESTDIR)/rtl8192de
    @mkdir -p $(MODDESTDIR)/rtl8192ee
    @mkdir -p $(MODDESTDIR)/rtl8192se
    @mkdir -p $(MODDESTDIR)/rtl8723ae
    @mkdir -p $(MODDESTDIR)/rtl8723be
    @mkdir -p $(MODDESTDIR)/rtl8821ae
    @mkdir -p $(MODDESTDIR)/rtl8822be
    @install -p -D -m 644 rtl_pci.ko $(MODDESTDIR)
    @install -p -D -m 644 rtl_usb.ko $(MODDESTDIR)
    @install -p -D -m 644 rtlwifi.ko $(MODDESTDIR)
    @install -p -D -m 644 ./btcoexist/btcoexist.ko $(MODDESTDIR)/btcoexist
    @install -p -D -m 644 ./halmac/halmac.ko $(MODDESTDIR)/halmac
    @install -p -D -m 644 ./phydm/phydm_mod.ko $(MODDESTDIR)/phydm
    @install -p -D -m 644 ./rtl8188ee/rtl8188ee.ko $(MODDESTDIR)/rtl8188ee
    @install -p -D -m 644 ./rtl8192c/rtl8192c-common.ko $(MODDESTDIR)/rtl8192c
    @install -p -D -m 644 ./rtl8192ce/rtl8192ce.ko $(MODDESTDIR)/rtl8192ce
    @install -p -D -m 644 ./rtl8192cu/rtl8192cu.ko $(MODDESTDIR)/rtl8192cu
    @install -p -D -m 644 ./rtl8192de/rtl8192de.ko $(MODDESTDIR)/rtl8192de
    @install -p -D -m 644 ./rtl8192ee/rtl8192ee.ko $(MODDESTDIR)/rtl8192ee
    @install -p -D -m 644 ./rtl8192se/rtl8192se.ko $(MODDESTDIR)/rtl8192se
    @install -p -D -m 644 ./rtl8723ae/rtl8723ae.ko $(MODDESTDIR)/rtl8723ae
    @install -p -D -m 644 ./rtl8723be/rtl8723be.ko $(MODDESTDIR)/rtl8723be
    @install -p -D -m 644 ./rtl8821ae/rtl8821ae.ko $(MODDESTDIR)/rtl8821ae
    @install -p -D -m 644 ./rtl8822be/rtl8822be.ko $(MODDESTDIR)/rtl8822be
    ifeq ($(COMPRESS_GZIP), y)
    @gzip -f $(MODDESTDIR)/*.ko
    @gzip -f $(MODDESTDIR)/btcoexist/*.ko
    @gzip -f $(MODDESTDIR)/halmac/*.ko
    @gzip -f $(MODDESTDIR)/phydm/*.ko
    @gzip -f $(MODDESTDIR)/rtl8*/*.ko
    endif
    ifeq ($(COMPRESS_XZ), y)
    @xz -f $(MODDESTDIR)/*.ko
    @xz -f $(MODDESTDIR)/btcoexist/*.ko
    @xz -f $(MODDESTDIR)/halmac/*.ko
    @xz -f $(MODDESTDIR)/phydm/*.ko
    @xz -f $(MODDESTDIR)/rtl8*/*.ko
    endif

    @depmod -a

    @#copy firmware images to target folder
    @cp -fr firmware/rtlwifi/ $(FIRMWAREDIR)/
    @echo "Install rtlwifi SUCCESS"

    uninstall:
    ifneq (,$(wildcard ./backup_drivers.tar))
    @echo Restoring backups
    @tar xvPf backup_drivers.tar
    endif

    @depmod -a

    @echo "Uninstall rtlwifi SUCCESS"

    clean:
    @find halmac/ \( -name "*.mod.c" -o -name "*.mod" -o -name "*.o" -o -name ".*.cmd" -o -name "*.ko" -o -name "*~" \) -exec rm {} \;
    @find phydm/ \( -name "*.mod.c" -o -name "*.mod" -o -name "*.o" -o -name ".*.cmd" -o -name "*.ko" -o -name "*~" \) -exec rm {} \;
    @rm -fr *.mod.c *.mod *.o .*.cmd *.ko *~
    @rm -fr rtl8*/*.mod.c rtl8*/*.mod rtl8*/*.o rtl8*/.*.cmd rtl8*/*.ko rtl8*/*~
    @rm -fr bt*/*.mod.c bt*/*.mod bt*/*.o bt*/.*.cmd bt*/*.ko bt*/*~
    @rm -fr .tmp_versions
    @rm -fr Modules.symvers
    @rm -fr Module.symvers
    @rm -fr Module.markers
    @rm -fr modules.order

  5. #5
    Join Date
    2016-Oct
    Location
    /dev/sda
    Posts
    928
    @when123 Have you installed linux-headers?

  6. #6
    Join Date
    2013-Apr
    Posts
    163
    Quote Originally Posted by _defalt View Post
    @when123 Have you installed linux-headers?
    After i tried apt-get install linux-headers-$(uname -r)

    and make , it is another problem happened .

  7. #7
    Join Date
    2013-Apr
    Posts
    163
    root@Debain:~# apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    linux-headers-4.15.0-kali2-amd64 is already the newest version (4.15.11-1kali1).
    linux-headers-4.15.0-kali2-amd64 set to manually installed.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    # git clone https://github.com/rtlwifi-linux/rtlwifi-next
    Cloning into 'rtlwifi-next'...
    remote: Counting objects: 3070, done.
    remote: Total 3070 (delta 0), reused 0 (delta 0), pack-reused 3070
    Receiving objects: 100% (3070/3070), 2.34 MiB | 23.00 KiB/s, done.
    Resolving deltas: 100% (2494/2494), done.
    root@Debain:~# cd rtlwifi-next/
    root@Debain:~/rtlwifi-next# ls
    base.c debug.c LICENSE pwrseqcmd.h rtl8192ce rtl8723com wifi.h
    base.h debug.h Makefile rc.c rtl8192cu rtl8821ae
    btcoexist efuse.c pci.c rc.h rtl8192de rtl8822be
    cam.c efuse.h pci.h regd.c rtl8192ee stats.c
    cam.h firmware phydm regd.h rtl8192se stats.h
    core.c halmac ps.c rtl8188ee rtl8723ae usb.c
    core.h Kconfig ps.h rtl8192c rtl8723be usb.h
    root@Debain:~/rtlwifi-next# make configure
    make: *** No rule to make target 'configure'. Stop.
    root@Debain:~/rtlwifi-next# make
    make -C /lib/modules/4.15.0-kali2-amd64/build M=/root/rtlwifi-next modules
    make[1]: Entering directory '/usr/src/linux-headers-4.15.0-kali2-amd64'
    CC [M] /root/rtlwifi-next/base.o
    /root/rtlwifi-next/base.c: In function ‘_rtl_init_deferred_work’:
    /root/rtlwifi-next/base.c:460:2: error: implicit declaration of function ‘setup_timer’; did you mean ‘sk_stop_timer’? [-Werror=implicit-function-declaration]
    setup_timer(&rtlpriv->works.watchdog_timer,
    ^~~~~~~~~~~
    sk_stop_timer
    cc1: some warnings being treated as errors
    /usr/src/linux-headers-4.15.0-kali2-common/scripts/Makefile.build:329: recipe for target '/root/rtlwifi-next/base.o' failed
    make[4]: *** [/root/rtlwifi-next/base.o] Error 1
    /usr/src/linux-headers-4.15.0-kali2-common/Makefile:1528: recipe for target '_module_/root/rtlwifi-next' failed
    make[3]: *** [_module_/root/rtlwifi-next] Error 2
    Makefile:146: recipe for target 'sub-make' failed
    make[2]: *** [sub-make] Error 2
    Makefile:8: recipe for target 'all' failed
    make[1]: *** [all] Error 2
    make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-kali2-amd64'
    Makefile:100: recipe for target 'all' failed
    make: *** [all] Error 2

  8. #8
    Join Date
    2013-Apr
    Posts
    163
    @_default @1st_daum ,I solved the wifi problem now .

    the details is followed

    https://github.com/lwfinger/rtlwifi_new



    You will need to install "make", "gcc", "kernel headers", "kernel build essentials", and "git".

    If you are running Ubuntu, then

    sudo apt-get install linux-headers-generic build-essential git

    Please note the first paragraph above.

    For all distros:
    git clone https://github.com/lwfinger/rtlwifi_new.git
    cd rtlwifi_new
    git checkout origin/extended -b extended
    sudo make install
    sudo modprobe -r rtl8822be


    depmod -a

    update-initramfs -u

    reboot



    and working well now .

    hope this can help

Similar Threads

  1. cant get wifi to work with rtl8723be
    By nos hit in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-12-29, 07:43
  2. Failed to load module "canberra-gtk-module"
    By kal in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-12-08, 13:28

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •