Results 1 to 4 of 4

Thread: Firmware ath9k_htc error

  1. #1
    Join Date
    2018-Feb
    Posts
    3

    Question Firmware ath9k_htc error

    Hello, this is my first time on kali, i'm not very used to linux environment (i have lubuntu on my laptop but that's it).

    I'm using Oracle Virtual Box with the latest version of kali linux installed.

    The wired connection works fine, however, my TP-link TL-WN722N doesn't work.

    It is detected but there's a download error apparently.

    Here's the lsusb cmd prompt :
    Code:
    root@kali:~# lsusb
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n
    Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    But there's an error with dmesg :
    Code:
    [   89.996656] usb 1-2: new high-speed USB device number 3 using xhci_hcd
    [   90.313560] usb 1-2: config 1 interface 0 altsetting 0 bulk endpoint 0x83 has invalid maxpacket 64
    [   90.313562] usb 1-2: config 1 interface 0 altsetting 0 bulk endpoint 0x4 has invalid maxpacket 64
    [   90.314528] usb 1-2: New USB device found, idVendor=0cf3, idProduct=9271
    [   90.314530] usb 1-2: New USB device strings: Mfr=16, Product=32, SerialNumber=48
    [   90.314530] usb 1-2: Product: USB2.0 WLAN
    [   90.314531] usb 1-2: Manufacturer: ATHEROS
    [   90.314532] usb 1-2: SerialNumber: 12345
    [   90.356834] usb 1-2: ath9k_htc: Firmware ath9k_htc/htc_9271-1.dev.0.fw requested
    [   90.357453] usbcore: registered new interface driver ath9k_htc
    [   90.358327] usb 1-2: firmware: direct-loading firmware ath9k_htc/htc_9271-1.dev.0.fw
    [   91.372201] usb 1-2: ath9k_htc: Firmware - ath9k_htc/htc_9271-1.dev.0.fw download failed
    [   91.372284] usb 1-2: ath9k_htc: USB layer deinitialized
    the firmware-atheros is installed, the adapter works on my laptop with lubuntu.

    Any idea of what I should do ?
    Please tell me if you need more information.
    Thank you !

  2. #2
    Join Date
    2016-Dec
    Posts
    210
    You probably have to install the extensions on virtualbox (on your host, not in the vm) and set the USB port to 2.0

  3. #3
    Join Date
    2018-Feb
    Posts
    3
    Hello, thanks for your answer!

    I've installed the extension pack and have set the USB port to 2.0 already, but it still doesn't work.
    http://puu.sh/zhoQp/b06f30b3a9.png

  4. #4
    Join Date
    2018-Feb
    Posts
    3
    I tried a different VM software and it works great.
    So I assume the error comes from Oracle VirtualBox, but I don't know how to fix it...


    EDIT: Fixed it, I safely removed the device in windows, removed the USB filter and add it again in virtualBox, it appears to work now for some reason
    Last edited by Superbit5950; 2018-02-07 at 16:55.

Similar Threads

  1. 3.20-20170903-2143 Nethunter Issues - ath9k_htc Req Firmware Upgrade
    By extreme.seventh in forum NetHunter General Questions
    Replies: 2
    Last Post: 2017-09-12, 02:58
  2. ath10k/pre-cal-pci-0000:03:00.0.bin firmware error
    By anguilla1980 in forum Installing Archive
    Replies: 3
    Last Post: 2017-07-21, 16:34
  3. WN7222N usb 1-1: ath9k_htc: Firmware - htc_9271.fw download failed
    By sruby in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-11-02, 10:57
  4. USB WiFi card W-722N firmware error
    By Froggs in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-08-10, 14:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •