Results 1 to 2 of 2

Thread: Unable to install libc6 (Kernel must be upgraded) - Error

  1. #1
    Join Date
    2018-Feb
    Posts
    4

    Unable to install libc6 (Kernel must be upgraded) - Error

    When performing an apt-get upgrade, i receive:
    Code:
    Kernel must be upgraded. This version of the GNU libc requires kernel version 3.2 or later. Please upgrade your kernel before installing glibc
    when the upgrade attemps to install libc6.

    I'm also stuck in a dependency loop and am unable to apt-get anything, example:
    Code:
    apt-get install xsltproc
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     libc-dev-bin : Depends: libc6 (> 2.26) but 2.19-18 is to be installed
     libc6-dev : Depends: libc6 (= 2.26-4) but 2.19-18 is to be installed
     locales : Depends: libc-bin (> 2.26) but 2.19-18 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    My /etc/apt/sources.list is as follows:
    Code:
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    Does anyone know what i can try to resolve this issue?

  2. #2
    Join Date
    2018-Feb
    Posts
    4
    Ok, issue resolved. The issue is my Android kernel has no recent updates so i'm stuck in an old version. I did the following to resolve the issue:
    1. Uninstall chroot and completely uninstall nethunter
    2. Reinstall nethunter and chroot
    3. Change repo to:
    deb http://old.kali.org/kali sana main non-free contrib
    and remove all other repo's
    4. apt-get update
    5. apt-get upgrade

Similar Threads

  1. Unable to install ATI drivers under 3.18 kernel
    By martin in forum General Archive
    Replies: 1
    Last Post: 2015-02-12, 09:10
  2. Replies: 1
    Last Post: 2014-02-06, 10:38

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •