Results 1 to 4 of 4

Thread: Difficulties installing Kali to USB

  1. #1
    Join Date
    2015-May
    Posts
    2

    Difficulties installing Kali to USB

    I have Kali ISO loaded onto a USB which I have booted into then used "Graphical Install" to install Kali onto another USB stick which I intend to use as the main drive for the OS
    I have my boot order setup to load into this USB..
    The install seemed to go fine, no obvious problems.. was a little slower than I expected but put that down to the USB I loaded the ISO onto was only USB2.0

    I removed the install USB and booted into the OS..
    I experience a black screen for about 10-15 seconds with a flashing icon.. then it loads into BusyBox and gives me the initramfs command prompt..

    Above all that I see the following:

    Gave up waiting for root file system device. Common problems:
    - Boot arg (cat /proc/cmdline)
    - Check rootdelay= (did the system wait long enough?)
    - Missing modules (cat /proc/modules; ls dev)
    ALERT! /dev/sdg1 does not exist. Dropping to a shell!



    Any Ideas??
    I didn't setup partitions during the install, I used entire disk (as the USB will be entirely used for Kali).. the system setup a 33gb swap and the rest "/"

    If you need anymore information to help pinpoint the issue please let me know.

    I tried this twice thinking the first install went a bit funny but got the same result both times.

  2. #2
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    209
    Quote Originally Posted by InfoH View Post
    I have Kali ISO loaded onto a USB which I have booted into then used "Graphical Install" to install Kali onto another USB stick which I intend to use as the main drive for the OS
    I have my boot order setup to load into this USB..
    The install seemed to go fine, no obvious problems.. was a little slower than I expected but put that down to the USB I loaded the ISO onto was only USB2.0

    I removed the install USB and booted into the OS..
    I experience a black screen for about 10-15 seconds with a flashing icon.. then it loads into BusyBox and gives me the initramfs command prompt..

    Above all that I see the following:

    Gave up waiting for root file system device. Common problems:
    - Boot arg (cat /proc/cmdline)
    - Check rootdelay= (did the system wait long enough?)
    - Missing modules (cat /proc/modules; ls dev)
    ALERT! /dev/sdg1 does not exist. Dropping to a shell!



    Any Ideas??
    I didn't setup partitions during the install, I used entire disk (as the USB will be entirely used for Kali).. the system setup a 33gb swap and the rest "/"

    If you need anymore information to help pinpoint the issue please let me know.

    I tried this twice thinking the first install went a bit funny but got the same result both times.
    This type of install is wierded me out too. Something about moving the kernal (bootloader) over to the second usb doesnt get completed. Keep trying youll get it. Ive used programs in windows that can turn your usb into a bootable drive.

  3. #3
    Join Date
    2015-May
    Posts
    2
    got it working in the end
    I mounted the ISO onto a USB stick then used that to graphical install to another USB stick.. think maybe the original installer was corrupt..
    burned the ISO to a disc and installed to USB from there.. works fine now

  4. #4
    For me Kali works well with a USB pendrive

Similar Threads

  1. Replies: 1
    Last Post: 2016-12-22, 09:35
  2. Installing and updating packages also installing kali repo issues.
    By gogito in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-08-15, 18:52
  3. Replies: 0
    Last Post: 2016-01-12, 14:07
  4. Replies: 0
    Last Post: 2014-02-10, 08:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •