Results 1 to 4 of 4

Thread: Install fails because 4.14.0 kernel on installation disk won't boot

Threaded View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2018-Feb
    Posts
    2

    Question Install fails because 4.14.0 kernel on installation disk won't boot

    When I boot off of the usb stick, the linux load command succeeds, the initrdef load command succeeds and the implied boot command seems to succeed, but the boot hangs before the black console screen comes up. This is a problem with the 4.14.0 kernel, but not with the 4.12.0 kernel. Something in the configuration changed between 4.12.0 and 4.14.0 that confounds my system. The same boot stick works ok with other intel ia64 systems. Are there any suggestions for boot options that I might try that would either collect more debug data or alleviate the problem. My system that fails is a Microsoft Surface Book with GPU.

    03/07/2018:
    I installed the 4.14.0 kernel in my boot directory and managed to get it to produce the following diagnostic after 3 other ACPI messages that were also produce by the 4.12.0 kernel when it booted successfully. The messages are:

    <timestamp> ACPI-Exception: Could not find/resolve named package element: SKC
    1 (20170728/dspkginit-381)
    <timestamp> ACPI-Exception: Could not find/resolve named package element: SKC
    2 (20170728/dspkginit-381)

    Is this condition part of Kali code in the kernel - it does not appear to be in the stock linux system.
    Thanks
    Last edited by woa46000; 2018-03-08 at 04:18. Reason: Found new message.

Similar Threads

  1. Kali installation stuck at Install the GRUB boot loader on a hard disk
    By salman.ali.geek in forum Installing Archive
    Replies: 10
    Last Post: 2018-01-31, 22:56
  2. Encrypted LVM install fails to boot
    By stefanhinote in forum Installing Archive
    Replies: 36
    Last Post: 2014-12-17, 02:23
  3. [Installation] Installing on a USB HDD, fails at install step.
    By kingkong101 in forum Installing Archive
    Replies: 1
    Last Post: 2014-11-08, 05:03
  4. Manually-partitioned, LVM-encrypted install fails to boot
    By Sandwiches in forum Installing Archive
    Replies: 4
    Last Post: 2014-03-01, 05:11
  5. Replies: 0
    Last Post: 2014-01-27, 14:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •