Results 1 to 4 of 4

Thread: Problems starting virtualbox on kali linux operating system

  1. #1
    Join Date
    2018-Feb
    Posts
    2

    Problems starting virtualbox on kali linux operating system

    I installed virtualbox on my kali linux operating system, but when i opened virtualbox i got the following;


    The character device /dev/vboxdrv does not exist.
    Please install the virtualbox-dkms package and the appropriate
    headers, most likely linux-headers-amd64.

    You will not be able to start VMs until this problem is fixed.
    root@kali:~#



    I have searched for and tried different answers on google.

    When I tried this particular one;

    sudo apt-get install build-essential dkms sudo apt-get remove --purge virtualbox-dkms
    sudo apt-get install virtualbox-dkms

    Virtualbox started without any problem, however, it installed a 32-bit virtualbox for me while my computer is 64-bit.
    Hence, I can't install kali amd64 on the 32-bit virtualbox.
    I would really appreciate getting a solution here.

  2. #2
    Join Date
    2016-Dec
    Posts
    223
    You installed a 32 bit OS, hence why it installed the 32 bit drivers. You can't install 64 bit drivers on a 32 bit OS, it will just not work (and you can't installed the X86 drivers on ARM or MIPS or any other CPU)

    Was there any error when installing? What were they?

    When starting virtualbox, what is the EXACT error? Have you looked it up?

  3. #3
    Join Date
    2018-Feb
    Posts
    2
    Thanks for your reply.
    As stated earlier, I downloaded and installed a kali linux amd64 iso.
    There were no errors installing the 32-bit virtualbox using : "apt-get install virtualbox-dkms"
    But using "apt-get install virtualbox" I got the following error;
    "Failed to start LSB: Virtualbox Linux Kernel Module"

    When starting virtualbox, I got the following error;

    "Kernel driver not installed (rc=-1908)

    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall virtualbox-dkms package and load the kernel module by executing

    'modprobe vboxdrv'

    as root.

    where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. "

  4. #4
    Join Date
    2016-Dec
    Posts
    223
    At this point, you probably want to reinstall the whole OS since it's probably messed up.

    Install the 64bit VirtualBox on the 64Bit OS and use apt-get whenever available.

Similar Threads

  1. Add operating system to my grub linux
    By davinciomar in forum Installing Archive
    Replies: 0
    Last Post: 2017-02-08, 14:18
  2. Replies: 3
    Last Post: 2016-02-01, 04:09
  3. Operating System Not Found after Kali Linux Installation
    By Djent in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2015-05-16, 17:45
  4. How to fix Missing Operating System after Kali Linux install
    By kprovost7314 in forum Installing Archive
    Replies: 1
    Last Post: 2014-10-13, 19:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •