Results 1 to 4 of 4

Thread: metasm in kali

  1. #1
    Join Date
    2013-Mar
    Location
    unknown
    Posts
    61

    metasm in kali

    in my metasm a have this error
    i using Kali 32 in virtualbox
    /root/foto.asm -o /root/foto.exe
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- metasm (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from peencode.rb:8:in `<main>'
    Last edited by Lancha; 2013-04-30 at 16:38.

  2. #2
    Join Date
    2013-Mar
    Posts
    269
    I half-way suspect you might have conflicting versions of ruby installed. Can you see if there are more than one installation with this command: "which -a ruby" ? If there is more than one listing, go ahead and get rid of the older one. If that is not the issue you might not have the right gems installed; paste the output of, "gem list" to see if you are missing any. (might be missing metasm?)
    Fact, Science and the Pursuit of Knowledge. Working to secure your networks from threats; Outside and Within.

  3. #3
    Join Date
    2013-Mar
    Location
    unknown
    Posts
    61
    i find the problem i forget the put in the site_ruby the files of metasm

  4. #4
    Join Date
    2014-Aug
    Posts
    15
    Hi,
    i found your Post about: peencode.rb
    but did not understand.

    Did you

    cp -r /usr/local/lib/site_ruby /usr/share/metasploit-framework/lib/metasm

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •