Results 1 to 5 of 5

Thread: Please update inetsim in Kali repo to 1.2.7. Current version (1.2.5) is incompatible with Perl

  1. #1
    Join Date
    2017-Nov
    Posts
    8

    Please update inetsim in Kali repo to 1.2.7. Current version (1.2.5) is incompatible with Perl

    Not sure if this is the right place to post this as it's not a question. But the latest version of inetsim in the Kali repository (1.2.5) is incompatible with the latest version of Perl in the Kali repository (5.26.1). It throws an error when trying to launch the DNS service that says "Insecure dependency in socket while running with -T switch at /usr/lib/perl/5.26/IO/Socket.pm line 80". This issue can be resolved by manually downloading inetsim 1.2.7 from http://www.inetsim.org/packages.html and installing with dpkg -i inetsim_1.2.7-1_all.deb. Thanks for your attention.

  2. #2
    Join Date
    2016-Dec
    Posts
    375
    If it isn't a debian package (can be checked using apt-cache show PACKAGENAME and look at the maintainer), then open an issue on https://bugs.kali.org with details

  3. #3
    Join Date
    2017-Nov
    Posts
    8
    It is a Debian package, but it's not the Kali repository.

  4. #4
    Join Date
    2017-Nov
    Posts
    8
    It looks like this has been addressed, thanks, but now there's an error when running apt-get upgrade or dist-upgrade and installing the new inetsim package. It throws an error saying it can't open /usr/share/inetsim/data/certs/default_key.pem for reading. I solved this by just deleting that file and the associated cert.

    But, I mean...how did this not get caught during testing? On the VM I just tried this on and ran into the error, I had never run inetsim. These files are part of the default install. This is not an edge case.

  5. #5
    Join Date
    2018-Mar
    Posts
    1
    Thanks for the post Cryptomancer. Solved the issue immediately.

    In regards to the permission issue with /var/lib/inetsim/certs/default_key.pem I noticed only root had RW.

    Fixed with the following:

    Code:
    sudo chmod 544 /var/lib/inetsim/certs/*

Similar Threads

  1. Install Python3.3.0 with current version intact
    By Mr10111011 in forum How-To Archive
    Replies: 3
    Last Post: 2017-01-25, 19:14
  2. How to update expired keys/signatures for repo?
    By my68_ in forum General Archive
    Replies: 5
    Last Post: 2015-04-19, 20:15
  3. Replies: 4
    Last Post: 2013-10-20, 18:50
  4. Chrome repo error at update
    By Reap3RGHS in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2013-05-30, 09:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •