Results 1 to 3 of 3

Thread: Unable to install metapackages on Kali on WSL

  1. #1

    Unable to install metapackages on Kali on WSL

    Hello again mates,
    Thanks to Re4son, I can use root on kow now.
    Now I encountered another problem here:
    I have updated and upgraded my kali, and installed kali-linux package with apt-get successfully.

    root@LAPTOP-N5F8O1GR:/# apt-get install kali-linux
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    kali-linux is already the newest version (2018.2.0).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    But when I tried to install kali-linux-full, some weird problems of dependencies caught me:


    root@LAPTOP-N5F8O1GR:/# apt-get install kali-linux-full
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kali-linux-full : Depends: acccheck but it is not installable
    Depends: irpas but it is not installable
    Depends: maltego but it is not installable
    Depends: maltego-teeth but it is not going to be installed
    Depends: nikto but it is not installable
    Depends: wce but it is not installable
    Depends: windows-binaries but it is not installable
    Depends: wpscan but it is not installable
    E: Unable to correct problems, you have held broken packages.



    I tried installing those depended package, but still failed. For example:
    root@LAPTOP-N5F8O1GR:/# apt-get install wce
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package wce is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'wce' has no installation candidate


    By the way, I can not even use wget in my kow:
    root@LAPTOP-N5F8O1GR:/# wget https://kali.sh/xfce4.sh
    bash: wget: command not found


    OK OK I admit I'm a **** junior rookie on linux here...... Thank you for your patient help mates

  2. #2
    Join Date
    2013-Mar
    Posts
    2

    Lightbulb

    I've been dealing with the same issue as you, regarding installing the kali-linux-full meta-package. for me the solution was to obtain a list of all packages in kali-linux-full (found here), and issue an "apt-get install" on all of them. fact being you and I ran into errors for packages not existing (or similar errors), I kept dealing with this issue until I got the apt-get command down to 1 single line that worked, keeping as many as I could from the original kali-linux-full packages.

    • here is the apt-get command that works on kali for WSL, as of 08/21/2018 (as close the original kali-linux-full meta-package as possible):
      Code:
      apt-get install -y kali-linux 0trace ace-voip afflib-tools aircrack-ng amap apache-users apktool armitage arp-scan arping arpwatch asleap automater autopsy backdoor-factory bbqsql bdfproxy bed beef-xss binwalk blindelephant bluelog blueranger bluesnarfer bluez bluez-hcidump braa btscanner bulk-extractor bully burpsuite cabextract cadaver cdpsnarf cewl cgpt cherrytree chirp chkrootkit chntpw cisco-auditing-tool cisco-global-exploiter cisco-ocs cisco-torch clang clusterd cmospwd commix copy-router-config cowpatty creddump crunch cryptcat cryptsetup curlftpfs cutycapt cymothoa darkstat davtest dbd dc3dd dcfldd ddrescue deblaze dex2jar dhcpig dirb dirbuster dmitry dnmap dns2tcp dnschef dnsenum dnsmap dnsrecon dnstracer dnswalk doona dos2unix dotdotpwn dradis driftnet dsniff dumpzilla eapmd5pass edb-debugger enum4linux enumiax ethtool ettercap-graphical ewf-tools exiv2 exploitdb extundelete fcrackzip fern-wifi-cracker fierce fiked fimap findmyhash flasm foremost fping fragroute fragrouter framework2 ftester funkload galleta gdb ghost-phisher giskismet golismero gpp-decrypt grabber guymager hackrf hamster-sidejack hash-identifier hashcat hashcat-utils hashdeep hashid hexinject hexorbase hotpatch hping3 httrack hydra hydra-gtk i2c-tools iaxflood ifenslave ike-scan inetsim intersect intrace inviteflood iodine jad javasnoop jboss-autopwn john johnny joomscan jsql-injection keimpx killerbee king-phisher kismet laudanum lbd leafpad libfindrtp libfreefare-bin libhivex-bin libnfc-bin lynis macchanger magicrescue magictree maskprocessor masscan mc mdbtools mdk3 medusa memdump metasploit-framework mfcuk mfoc mfterm mimikatz minicom miranda miredo missidentify mitmproxy msfpc multimac nasm nbtscan ncat-w32 ncrack ncurses-hexedit netdiscover netmask netsed netsniff-ng netwag nfspy ngrep nipper-ng nishang nmap ohrwurm ollydbg onesixtyone ophcrack ophcrack-cli oscanner p0f pack padbuster paros pasco passing-the-hash patator pdf-parser pdfid pdgmail perl-cisco-copyconfig pev pipal pixiewps plecost polenum powerfuzzer powersploit protos-sip proxychains proxystrike proxytunnel pst-utils ptunnel pwnat pyrit python-faraday python-impacket python-peepdf python-rfidiot python-scapy radare2 rainbowcrack rake rcracki-mt reaver rebind recon-ng recordmydesktop recoverjpeg redfang redsocks reglookup regripper responder rifiuti rifiuti2 rsmangler rtpbreak rtpflood rtpinsertsound rtpmixsound safecopy safecopy sakis3g samdump2 sbd scalpel scrounge-ntfs sctpscan sendemail set sfuzz sidguesser siege siparmyknife sipcrack sipp sipvicious skipfish sleuthkit smali smbmap smtp-user-enum sniffjoke snmpcheck socat sparta spectools spike spooftooph sqldict sqlitebrowser sqlmap sqlninja sqlsus sslcaudit ssldump sslh sslscan sslsniff sslsplit sslstrip sslyze statsprocessor stunnel4 suckless-tools sucrack swaks t50 tcpflow tcpick tcpreplay termineter tftpd32 thc-ipv6 thc-pptp-bruter thc-ssl-dos theharvester tlssled tnscmd10g truecrack twofi u3-pwn ua-tester udptunnel unicornscan uniscan unix-privesc-check urlcrazy vboot-kernel-utils vboot-utils vim-gtk vinetto vlan voiphopper volafox volatility vpnc wafw00f wapiti webacoo webscarab webshells weevely wfuzz whatweb wifi-honey wifitap wifite winexe wireshark wol-e wordlists xpdf xprobe xspy xsser xtightvncviewer yersinia zaproxy zenmap zim

    • here is the list of packages which failed, and below that is each error experienced:
      Code:
      ferret-sidejack
      irpas
      maltego
      maltego-teeth 
      nikto
      wce
      windows-binaries
      wpscan
      recstudio
      iputils-arping
    • individual package errors (in case anyone wonders, I did apt-get update, upgrade, dist-upgrade, etc yet still obtained these errors):
      Code:
      E: Unable to locate package ferret-sidejack
      E: Package 'irpas' has no installation candidate
      E: Package 'maltego' has no installation candidate
      E: Package 'nikto' has no installation candidate
      E: Unable to locate package recstudio
      E: Package 'wce' has no installation candidate
      E: Package 'windows-binaries' has no installation candidate
      E: Package 'wpscan' has no installation candidate
      E: Unable to locate package recstudio

  • #3
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    326
    Quote Originally Posted by Long the oriental dragon View Post
    Hello again mates,
    Thanks to Re4son, I can use root on kow now.
    Now I encountered another problem here:
    I have updated and upgraded my kali, and installed kali-linux package with apt-get successfully.

    root@LAPTOP-N5F8O1GR:/# apt-get install kali-linux
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    kali-linux is already the newest version (2018.2.0).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    But when I tried to install kali-linux-full, some weird problems of dependencies caught me:


    root@LAPTOP-N5F8O1GR:/# apt-get install kali-linux-full
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    kali-linux-full : Depends: acccheck but it is not installable
    Depends: irpas but it is not installable
    Depends: maltego but it is not installable
    Depends: maltego-teeth but it is not going to be installed
    Depends: nikto but it is not installable
    Depends: wce but it is not installable
    Depends: windows-binaries but it is not installable
    Depends: wpscan but it is not installable
    E: Unable to correct problems, you have held broken packages.



    I tried installing those depended package, but still failed. For example:
    root@LAPTOP-N5F8O1GR:/# apt-get install wce
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package wce is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package 'wce' has no installation candidate


    By the way, I can not even use wget in my kow:
    root@LAPTOP-N5F8O1GR:/# wget https://kali.sh/xfce4.sh
    bash: wget: command not found


    OK OK I admit I'm a **** junior rookie on linux here...... Thank you for your patient help mates
    To the message after this ferret is a 32bit program. So find forum about installing 32 bit to 64 bit
    easy to start; hard to finish

  • Similar Threads

    1. Nethunter can't install metapackages
      By woobamedia in forum Installing NetHunter
      Replies: 13
      Last Post: 2017-10-29, 02:50
    2. Cannot install metapackages (temporary failure resolving)
      By redbeardtheweird in forum NetHunter General Questions
      Replies: 10
      Last Post: 2017-04-05, 13:41
    3. Issue: can't add metapackages from Kali chroot manager
      By proxymus in forum Installing NetHunter
      Replies: 0
      Last Post: 2016-04-15, 12:35

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •