Results 1 to 2 of 2

Thread: WLAN (iwlwifi-6000) Not detecting in kali in win 10 WSL

  1. #1
    Join Date

    Angry WLAN (iwlwifi-6000) Not detecting in kali in win 10 WSL

    I am planning to use kali linux alongside with my running system as WSL offer its easily. now the problem is my wlan is not working properly. I cant figure out exact problem.
    My wireless card is: Intel® Centrino® Advanced-N 6200

    when I execute ifconfig

    wifi0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500        inet  netmask  broadcast
            inet6 fe80::6522:fc06:1ce:324e  prefixlen 64  scopeid 0x0<global>
            unspec 00-23-14-F5-39-7D-00-00-00-00-00-00-00-00-00-00  (UNSPEC)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    and iwconfig

    x@ZL:~$ iwconfigeth0      no wireless extensions.
    lo        no wireless extensions.
    wifi0     no wireless extensions.
    eth1      no wireless extensions.

    I tried all possible way but i cant update firmware for iwlwifi-6000. I tried it seems firmware update successful,
    x@ZL:~$ wget not apply HSTS. The HSTS database must be a regular and non-world-writable file.
    ERROR: could not open HSTS store at '/home/x/.wget-hsts'. HSTS will be disabled.
    --2018-04-05 06:18:05--
    Resolving (,
    Connecting to (||:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 216806 (212K) [application/octet-stream]
    Saving to: ‘iwlwifi-6000-ucode-’
    iwlwifi-6000-ucode-   100%[===============================================================>] 211.72K   151KB/s    in 1.4s
    2018-04-05 06:18:08 (151 KB/s) - ‘iwlwifi-6000-ucode-’ saved [216806/216806]
    x@ZL:~$ tar -xvzf iwlwifi-6000-ucode-
    x@ZL:~$ cd iwlwifi-6000-ucode-
    x@ZL:~/iwlwifi-6000-ucode-$ sudo cp iwlwifi-6000-4.ucode /lib/firmware
    x@ZL:~/iwlwifi-6000-ucode-$ sudo ls -al /lib/firmware/iwlwifi-6000*
    -rw-r--r-- 1 root root 454608 Apr  5 06:19 /lib/firmware/iwlwifi-6000-4.ucode

    But it shows,

    x@ZL:~$ sudo dmesg | grep iwl
    dmesg: read kernel buffer failed: Function not implemented

    I dont know the problem, can u guys help me out of this annoying experience.

    thank you.

  2. #2
    Join Date
    Probably a limitation of WSL

Similar Threads

  1. iwlwifi not found on Kali 4.4
    By fl@w§eeker in forum Installing Archive
    Replies: 3
    Last Post: 2016-09-16, 16:44
  2. Missing iwlwifi-3160 when installing Kali 2.0
    By juanvelasco in forum Installing Archive
    Replies: 3
    Last Post: 2015-10-17, 17:09
  3. Replies: 0
    Last Post: 2014-08-04, 15:46
  4. Replies: 5
    Last Post: 2014-07-06, 01:22

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts