Results 1 to 3 of 3

Thread: /dev/root is almost full

  1. #1

    /dev/root is almost full

    Hi there!

    I've installed Kali Linux on a Raspberry Pi (used the right version for that). My SD-card is 16GB in size, though Kali only recognises 7GB. I noticed this after trying a dist-upgrade, it said /dev/root does not have enough space.

    This is a print of the " df -h" command:

    Filesystem      Size  Used Avail Use% Mounted on
    /dev/root       6.7G  6.5G     0 100% /
    devtmpfs        460M     0  460M   0% /dev
    tmpfs           464M     0  464M   0% /dev/shm
    tmpfs           464M   13M  452M   3% /run
    tmpfs           5.0M     0  5.0M   0% /run/lock
    tmpfs           464M     0  464M   0% /sys/fs/cgroup
    /dev/mmcblk0p1   61M   22M   40M  35% /boot
    tmpfs            93M  4.0K   93M   1% /run/user/109
    tmpfs            93M     0   93M   0% /run/user/0
    I noticed /dev/root is only 6.7G, my SD card is 16.
    fdisk -l showed "/dev/mmcblk0" was also 6.7G. I expanded this to 15G.

    The only issue is that /dev/root is still 6.7G and almost full.
    Using this tutorial I tried to increase dev/root's size:

    The problem is that I cannot use the command "resize2fs /dev/mmcblk0p2".
    I get the following notification:

    Filesystem at /dev/mmcblk0p2 is mounted on /; on-line resizing required
    old_desc_blocks = 1, new_desc_blocks = 2
    resize2fs: Permission denied to resize filesystem
    I've been at this for three hours, but I don't seem to be able to successfully increase the size of /dev/root. How can I fully utulize the 16GB on this SD-card?
    Apparently I cannot resize it because I'm using that partition.

    I'm connected through SSH so "gparted" does not work. I can only remotely access my PI with SSH (this is a school assignment). So far I've tried everything I can imagine, but I don't seem to succeed.

    Can someone please help me?
    Thanks in advance.

  2. #2
    Join Date
    The resize needs to be done on a pc/Mac. A running system always has / mounted.

  3. #3
    I used gparted to resize my 32gb sd card. Try to give that a shot.

Similar Threads

  1. Replies: 0
    Last Post: 2021-10-14, 18:33
  2. Nethunter hunter differences - No Root / Root / NetHunter Image
    By drac13 in forum NetHunter General Questions
    Replies: 1
    Last Post: 2021-03-23, 16:16
  3. nethunter no root access can't root with adb
    By bobmollleman in forum NetHunter General Questions
    Replies: 0
    Last Post: 2015-08-30, 14:35
  4. Replies: 3
    Last Post: 2015-05-23, 20:11

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts