Results 1 to 3 of 3

Thread: Kali WSL GUI problem

  1. #1
    Join Date
    2018-Apr
    Posts
    1

    Unhappy Kali WSL GUI problem

    So, My problem is, I do everything like the tutorial on the kali web page says and when I succesfully connect to the wsl using remote acces. it says :
    connecting to sesman ip [localhost] port 3350
    sesman connect ok
    sending login info blabla
    login succesful for display 11
    started connecting
    connection problem, giving up
    some problem

    i tried many times,same results it shows nothing for a moment the screen is blue then there is just the connection log box popping up.
    I think the issue is that my graphic card isn't compatible with linux.
    PC: HP ProBook x360 11-g1
    cpu: Intel Celeron N3450 1.1GHz
    gpu: Intel Hd Graphics
    how can i update the gpu so it can be compatible, or should I just take another computer because this one is doomed because it can't even boot kali on a flashdrive with safeboot off.
    Anyway, Help me if you can, thanks !

  2. #2
    Join Date
    2018-Apr
    Posts
    1
    I am having the exact same problem with the same error message. I am running Intel HD Graphics also.

  3. #3
    Join Date
    2018-Apr
    Posts
    1
    =| Kali Linux on Win 10 |=


    [First Install]
    sudo cat /etc/issue
    sudo apt-get update
    sudo apt-get dist-upgrade (y)
    sudo apt-get install webshells [you may need to allow access via defender / smartscreen]
    sudo apt-get clean
    sudo apt-get install webshells [re-do if first time blocked by defender / smartscreen]
    ls -l /usr/share/webshells/
    sudo wget https://kali.sh/xfce4.sh
    sudo cat xfce4.sh
    sudo sh xfce4.sh
    sudo /etc/init.d/xrdp start


    sudo /etc/init.d/xrdp stop (ogni qualvolta non si dovrÓ utilizzare la GUI di Kali Linux)


    # Upgrade OS
    sudo apt-get update -y && apt-get upgrade -y
    sudo apt-get dist-upgrade -y
    sudo apt-get install xrdp lxde-core lxde tigervnc-standalone-server -y


    sudo update-alternatives --config x-session-manager
    # choose xfce4-session


    # edit xrdp.ini
    sudo nano /etc/xrdp/xrdp.ini
    autorun=sesman-any
    max_bpp=16
    [sesman-any]
    ip=127.0.0.1
    # changed username and password to the kali user

    # Mod access permission
    sudo nano /etc/X11/Xwrapper.config
    allowed_users=anybody


    # edit sesman.ini
    sudo nano /etc/xrdp/sesman.ini
    [Globals]
    ListenAddress=127.0.0.1
    ListenPort=3390
    EnableUserWindowManager=true
    UserWindowManager=startwm.sh
    DefaultWindowManager=startwm.sh

    # start services
    sudo service xrdp start
    sudo service xrdp-sesman start


    # conf services
    sudo update-rc.d xrdp enable
    sudo systemctl enable xrdp-sesman.service



    [First GUI Start]
    Open terminal
    sudo cat /etc/issue

    By Ne0

Similar Threads

  1. Reaver/Bully problem. Kali problem? backports problems?
    By kaputjan in forum General Archive
    Replies: 2
    Last Post: 2017-04-28, 17:48

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •