Results 1 to 2 of 2

Thread: Unable to configure Masscan

  1. #1
    Join Date
    2018-Apr
    Location
    Florida
    Posts
    1

    Unable to configure Masscan

    I'm trying Exercise 4 of chapter 5 on the Kali Linux Revealed online course: https://kali.training/topic/exercise...web-interface/

    I followed all the steps exactly, but when I open up the webpage, I get quite a few errors. I've tried this both on a laptop, and a VM and they both have the exact same errors. Here's a screenshot of the page:

    https://gyazo.com/029eda6833b1bd99f12c0b3e45f66dcc

    I double checked, and php-xml is on the list of packages it has you install. To make sure, I tried purging that package, and installing it again. I've double checked the services are running, the config.php files which can be seen on the screenshot, and I've tried reaching the page from the machine itself, and from another computer connecting to it. Any ideas on what's causing these error? Thanks in advance.

    UPDATE:
    Solved.

    Figured the issue was going to be a wrong version of something, somewhere along the line, but I wasn't really sure how to confirm that. Ended up needing php 7.0 versions of the packages which was resolved by just adding 7.0 to the end of all the installs (apt install php7.0-pgsql php7.0-xml)
    Last edited by maiki; 6 Days Ago at 08:58. Reason: Merge Posts

  2. #2
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    177
    Glad you got it sorted.

    I've elaborated on my previous post and added a little HOWTO for dealing with these php version mismatches in the Kali training forum:

    https://kali.training/forums/topic/m...can/#post-3769
    ----------------------------------------
    https://re4son-kernel.com
    - - - - - - - - - - - - - - - - - - - - - -
    Check out "Sticky Fingers Kali-Pi":
    https://re4son.com/kali-pi

    Now with mana-toolkit and more goodies!

Similar Threads

  1. Masscan UI // Webpage ~ php5 php5-mysql mysql-server
    By Ceruleancerise in forum General Archive
    Replies: 2
    Last Post: 2017-07-02, 13:16
  2. how configure the stunnel
    By Lancha in forum General Archive
    Replies: 2
    Last Post: 2013-11-24, 13:53
  3. ./ configure problem
    By Ramachandran in forum General Archive
    Replies: 0
    Last Post: 2013-05-27, 06:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •