Results 1 to 4 of 4

Thread: Live USB kernel version is wrong, so rtl8812au driver install breaks

  1. #1
    Join Date

    Live USB kernel version is wrong, so rtl8812au driver install breaks

    I recently got my hands on an alfa AWUS036ACH adapter (thats an RTL8812AU chip) and wanted to give it a go on my persistent USB install. (note that I have tried and had the same problems on a simple live system. I'm booting from the most recent weekly image (also tried a stable image,) and the system is totally fresh. Now, what I did on my native system that worked fine was:

    sudo apt-get -y dist-upgrade
    apt update
    apt install realtek-rtl88xxau-dkms
    sudo modprobe 8812au
    sudo systemctl restart network-mananger
    However, as I had discovered earlier, the dist-upgrade updates the kernel, but the live USB cannot seem to update the kernel it's booting from (and the one uname refers to). This isn't normally a problem, but after a dist-upgrade, I have two folders in /lib/modules: 4.14.0-kali3-amd64 (my old kernel) and 4.15.0-kali2-amd64 (the new one). Only using apt update does not create the second folder, but when I attempt to install the driver, it creates it. The make and build which aptitude is looking for are in the 4.15 folder, because the distribution has upgraded this, but the system still thinks I'm supposed to be using 4.14, so it looks there and gets confused. Specifically, in the install, I get
    Setting up linux-headers-4.15.0-kali2-amd64 (4.15.11-1kali1) ...
    Error! Bad return status for module build on kernel: 4.15.0-kali2-amd64 (x86_64)
    Consult /var/lib/dkms/realtek-rtl88xxau/5.1.5~20180125/build/make.log for more information.
    In the make.log file, it says "Make[1]: *** /lib/modules/4.14.0-kali3-amd64/build: No such file or Directory. Stop." So it's clearly looking in the wrong folder, dispite it being the command to updated the headers!
    Also, sudo modprobe <anything> says "modprobe: FATAL: Module <anything> not found in directory /lib/modules/4.14.0-kali3-amd64" So it's looking there too. I assume it's getting all this from uname, which also outputs the 4.14 file. I know there are some ways of updating the kernel manually on live USB, but I don't want to have to do that every week, and I'm not even sure it has ever worked for anyone...

    Runing apt install realtek-rtl88xxau-dkms installs new kernel headers, and then tries to build from the old kernel, which now has neither make nor build.

  2. #2
    Join Date
    You only have to update the kernel when you're installing a driver. I've heard it works.

    Another possibility is to download the weekly ISO and install it on your thumbdrive, you'll have an up to date kernel.

  3. #3
    Join Date
    Do you mean that my adapter should work out of the box in 2018? How can I test this? Also, I am running the newest weekly ISO, and it still updates the kernel when installing the driver.

  4. #4
    Join Date
    I'm also having the same issue. I installed kali on live usb with persistence and everything is working. I did full upgrade and then right after I installed the driver package like kali wants you to and it does not recognize the wifi adapter. When I use modprobe on the driver it is returning module not found in the 4.15.0-kali2-amd64 directory, but the newest kernel folder is of 4.16.0. It is looking for the driver in the wrong folder.

Similar Threads

  1. Kali Live USB Installation - Kernel version mismatch
    By baroud8812 in forum Installing Archive
    Replies: 2
    Last Post: 2015-07-23, 14:57

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts