Results 1 to 4 of 4

Thread: AMD Video Graphic RX580 Polaris 20 error

  1. #1
    Join Date
    2013-Apr
    Posts
    163

    AMD Video Graphic RX580 Polaris 20 error

    RX580 should be Polaris 20, but kali is polaris 10 loading , so there are so many problems loading GPU driver

    3.633376] amdgpu 0000:0c:00.0: firmware: failed to load amdgpu/polaris10_pfp_2.bin (-2)
    [ 3.633443] firmware_class: See https://wiki.debian.org/Firmware for information about missing firmware
    [ 3.633509] amdgpu 0000:0c:00.0: Direct firmware load for amdgpu/polaris10_pfp_2.bin failed with error -2
    [ 3.637321] amdgpu 0000:0c:00.0: firmware: direct-loading firmware amdgpu/polaris10_pfp.bin
    [ 3.637353] amdgpu 0000:0c:00.0: firmware: failed to load amdgpu/polaris10_me_2.bin (-2)
    [ 3.637423] amdgpu 0000:0c:00.0: Direct firmware load for amdgpu/polaris10_me_2.bin failed with error -2
    [ 3.639592] usbcore: registered new interface driver btusb
    [ 3.640546] amdgpu 0000:0c:00.0: firmware: direct-loading firmware amdgpu/polaris10_me.bin
    [ 3.640576] amdgpu 0000:0c:00.0: firmware: failed to load amdgpu/polaris10_ce_2.bin (-2)
    [ 3.640645] amdgpu 0000:0c:00.0: Direct firmware load for amdgpu/polaris10_ce_2.bin failed with error -2
    [ 3.645711] amdgpu 0000:0c:00.0: firmware: direct-loading firmware amdgpu/polaris10_ce.bin
    [ 3.648756] amdgpu 0000:0c:00.0: firmware: direct-loading firmware amdgpu/polaris10_rlc.bin
    [ 3.648787] amdgpu 0000:0c:00.0: firmware: failed to load amdgpu/polaris10_mec_2.bin (-2)
    [ 3.648855] amdgpu 0000:0c:00.0: Direct firmware load for amdgpu/polaris10_mec_2.bin failed with error -2
    [ 3.651996] amdgpu 0000:0c:00.0: firmware: direct-loading firmware amdgpu/polaris10_mec.bin
    [ 3.652025] amdgpu 0000:0c:00.0: firmware: failed to load amdgpu/polaris10_mec2_2.bin (-2)

    uname --all
    Linux debian 4.15.0-kali3-amd64 #1 SMP Debian 4.15.17-1kali1 (2018-04-25) x86_64 GNU/Linux

    Would some one can help with this ?

  2. #2
    Join Date
    2016-Dec
    Posts
    279
    Have you had a chance to search in google for the error message itself?
    Have you looked at the link provided in your error message?

    In any case, debian, as well as other distro usually package firmware and doing an apt-cache search radeon would show one package that might contain the files needed: firmware-amd-graphics

  3. #3
    Join Date
    2013-Apr
    Posts
    163
    apt-get install firmware-amd-graphics
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    firmware-amd-graphics is already the newest version (20170823-1).
    The following packages were automatically installed and are no longer required:
    python-compizconfig python3-h11
    Use 'apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


    ls -l /lib/firmware/amdgpu/ | grep polaris10
    -rw-r--r-- 1 root root 8832 Aug 27 2017 polaris10_ce.bin
    -rw-r--r-- 1 root root 130228 Aug 27 2017 polaris10_k_smc.bin
    -rw-r--r-- 1 root root 32708 Aug 27 2017 polaris10_mc.bin
    -rw-r--r-- 1 root root 17024 Aug 27 2017 polaris10_me.bin
    -rw-r--r-- 1 root root 262784 Aug 27 2017 polaris10_mec2.bin
    -rw-r--r-- 1 root root 262784 Aug 27 2017 polaris10_mec.bin
    -rw-r--r-- 1 root root 17024 Aug 27 2017 polaris10_pfp.bin
    -rw-r--r-- 1 root root 23984 Aug 27 2017 polaris10_rlc.bin
    -rw-r--r-- 1 root root 12692 Aug 27 2017 polaris10_sdma1.bin
    -rw-r--r-- 1 root root 12692 Aug 27 2017 polaris10_sdma.bin
    -rw-r--r-- 1 root root 130196 Aug 27 2017 polaris10_smc.bin
    -rw-r--r-- 1 root root 130196 Aug 27 2017 polaris10_smc_sk.bin
    -rw-r--r-- 1 root root 369696 Aug 27 2017 polaris10_uvd.bin
    -rw-r--r-- 1 root root 166816 Aug 27 2017 polaris10_vce.bin

  4. #4
    Join Date
    2013-Apr
    Posts
    163
    solved , find polaris10_pfp_2.bin polaris10_me_2.bin polaris10_ce_2.bin polaris10_mec_2.bin polaris10_mec2_2.bin on github . and copy them to lib/firmware/amdgpu

    and restart .

Similar Threads

  1. error loading amdgpu drivers AMD RX580 driver
    By when123 in forum Kali Linux TroubleShooting
    Replies: 0
    Last Post: 2018-05-05, 11:24
  2. Replies: 4
    Last Post: 2017-02-21, 08:42
  3. Replies: 0
    Last Post: 2015-09-09, 01:39
  4. Replies: 0
    Last Post: 2013-12-07, 16:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •