Results 1 to 7 of 7

Thread: Lenovo Touchpad not detected

  1. #1
    Join Date

    Lenovo Touchpad not detected

    Hello everyone,

    It has been over 2 years since I first posted on this forum. Over those 2 years, I have installed and used Kali Linux on a multitude of machines, and I would consider myself pretty good at using Linux (mostly backend, terminal stuff, not much experience in the Desktop Environment). Anyways, I recently upgraded my main Kali setup to a Lenovo Ideapad 320, and everything works perfectly - except one thing: the touchpad. It isn't recognized by lsusb or xinput, dmesg shows no hide nor hair of the thing, and there's nothing in Settings or Tweak Tool that suggests I have it turned off. Many people online have had issues with this laptop's touchpad which they have solved, but none of them were using Kali Linux, and none of their solutions worked for me.

    Here's what I tried:
    1. Redownload and reinstall Kali Linux
    2. apt-get update && apt-get upgrade
    3. Downgrade kernel from 4.90 to 4.15
    4. Install from a newer Kali ISO image (tried 2018.2 and 2018.1, both had the same problem so I went back to 2017.1 as it's my favorite)
    5. Checked and verified ISO hashes
    6. Installed this driver: (even though it's for Ubuntu)
    7. Added all kinds of i8042 tags to my GRUB default CMD line args
    8. Rebooted the machine several times after trying each of these

    Here's my xinput --list:
    \u23a1 Virtual core pointer                    	id=2	[master pointer  (3)]
    \u239c   \u21b3 Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    \u239c   \u21b3 USB Optical Mouse                       	id=12	[slave  pointer  (2)]
    \u23a3 Virtual core keyboard                   	id=3	[master keyboard (2)]
        \u21b3 Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        \u21b3 Power Button                            	id=6	[slave  keyboard (3)]
        \u21b3 Video Bus                               	id=7	[slave  keyboard (3)]
        \u21b3 Power Button                            	id=8	[slave  keyboard (3)]
        \u21b3 EasyCamera: EasyCamera                  	id=9	[slave  keyboard (3)]
        \u21b3 Ideapad extra buttons                   	id=10	[slave  keyboard (3)]
        \u21b3 AT Translated Set 2 keyboard            	id=11	[slave  keyboard (3)]
    * the "USB Optical Mouse" is my external mouse that I am using temporarily

    dmesg | grep mouse:
    [    0.847595] mousedev: PS/2 mouse device common for all mice

    Bus 003 Device 004: ID 13d3:5a02 IMC Networks 
    Bus 003 Device 003: ID 0bda:0821 Realtek Semiconductor Corp. 
    Bus 003 Device 005: ID 1bcf:0007 Sunplus Innovation Technology Inc. Optical Mouse
    Bus 003 Device 002: ID 0438:7900 Advanced Micro Devices, Inc. 
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 002: ID 18a5:0302 Verbatim, Ltd Flash Drive
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    cat /proc/bus/input/devices:
    I: Bus=0011 Vendor=0001 Product=0001 Version=ab83
    N: Name="AT Translated Set 2 keyboard"
    P: Phys=isa0060/serio0/input0
    S: Sysfs=/devices/platform/i8042/serio0/input/input0
    U: Uniq=
    H: Handlers=sysrq kbd leds event0 
    B: PROP=0
    B: EV=120013
    B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
    B: MSC=10
    B: LED=7
    I: Bus=0019 Vendor=0000 Product=0001 Version=0000
    N: Name="Power Button"
    P: Phys=PNP0C0C/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input3
    U: Uniq=
    H: Handlers=kbd event1 
    B: PROP=0
    B: EV=3
    B: KEY=10000000000000 0
    I: Bus=0019 Vendor=0000 Product=0005 Version=0000
    N: Name="Lid Switch"
    P: Phys=PNP0C0D/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input4
    U: Uniq=
    H: Handlers=event2 
    B: PROP=0
    B: EV=21
    B: SW=1
    I: Bus=0019 Vendor=0000 Product=0001 Version=0000
    N: Name="Power Button"
    P: Phys=LNXPWRBN/button/input0
    S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input5
    U: Uniq=
    H: Handlers=kbd event3 
    B: PROP=0
    B: EV=3
    B: KEY=10000000000000 0
    I: Bus=0019 Vendor=0000 Product=0006 Version=0000
    N: Name="Video Bus"
    P: Phys=LNXVIDEO/video/input0
    S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input6
    U: Uniq=
    H: Handlers=kbd event4 
    B: PROP=0
    B: EV=3
    B: KEY=3e000b00000000 0 0 0
    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HD-Audio Generic Mic"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:09.2/sound/card1/input7
    U: Uniq=
    H: Handlers=event5 
    B: PROP=0
    B: EV=21
    B: SW=10
    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HD-Audio Generic Headphone"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:09.2/sound/card1/input8
    U: Uniq=
    H: Handlers=event6 
    B: PROP=0
    B: EV=21
    B: SW=4
    I: Bus=0000 Vendor=0000 Product=0000 Version=0000
    N: Name="HDA ATI HDMI HDMI/DP,pcm=3"
    P: Phys=ALSA
    S: Sysfs=/devices/pci0000:00/0000:00:01.1/sound/card0/input9
    U: Uniq=
    H: Handlers=event7 
    B: PROP=0
    B: EV=21
    B: SW=140
    I: Bus=0019 Vendor=0000 Product=0000 Version=0000
    N: Name="Ideapad extra buttons"
    P: Phys=ideapad/input0
    S: Sysfs=/devices/pci0000:00/0000:00:14.3/PNP0C09:00/VPC2004:00/input/input10
    U: Uniq=
    H: Handlers=kbd rfkill event8 
    B: PROP=0
    B: EV=13
    B: KEY=101400800100c03 400000000300000 0 2
    B: MSC=10
    I: Bus=0010 Vendor=001f Product=0001 Version=0100
    N: Name="PC Speaker"
    P: Phys=isa0061/input0
    S: Sysfs=/devices/platform/pcspkr/input/input11
    U: Uniq=
    H: Handlers=kbd event9 
    B: PROP=0
    B: EV=40001
    B: SND=6
    I: Bus=0003 Vendor=13d3 Product=5a02 Version=1701
    N: Name="EasyCamera: EasyCamera"
    P: Phys=usb-0000:00:12.0-1.3/button
    S: Sysfs=/devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1.3/3-1.3:1.0/input/input12
    U: Uniq=
    H: Handlers=kbd event10 
    B: PROP=0
    B: EV=3
    B: KEY=100000 0 0 0
    I: Bus=0003 Vendor=1bcf Product=0007 Version=0110
    N: Name="USB Optical Mouse"
    P: Phys=usb-0000:00:12.0-1.1/input0
    S: Sysfs=/devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1.1/3-1.1:1.0/0003:1BCF:0007.0001/input/input13
    U: Uniq=
    H: Handlers=mouse0 event11 
    B: PROP=0
    B: EV=1f
    B: KEY=70000 0 0 0 0
    B: REL=143
    B: ABS=10000000000
    B: MSC=10
    uname -a:
    Linux device 4.15.0-kali3-amd64 #1 SMP Debian 4.15.17-1kali1 (2018-04-25) x86_64 GNU/Linux
    I need to get this working ASAP. Any help would be endlessly appreciated.

  2. #2
    Join Date
    same problems with my kali too , ASUS s7zc
    don't have drivers for touchpad .

  3. #3
    Join Date
    Quote Originally Posted by when123 View Post
    same problems with my kali too , ASUS s7zc
    don't have drivers for touchpad .
    Uon my laptop fn + f5 keys will turn touchpad on and off.
    easy to start; hard to finish

  4. #4
    Join Date

    Lenovo ideapd 320 touchpad not working

    I had the same problem in my lenovo ideapad 330, i tried to find the correct solution and finally got one

    You just have to update your kernal !!! I have upgraded my kernal to latest stable version which currently is

    wick@wicked:~$ uname -r

    kali linux version -

    wick@wicked:~$ uname -a
    Linux wicked 4.19.7 #1 SMP Fri Dec 7 12:17:48 IST 2018 x86_64 GNU/Linux

    Upgrade your kernal from

    get latest stable version--

    download or use
    $ wget

    it will get downloaded , then extract the file

    Then install the kernal

    In the process of updating kernal many errors might generate like

    # bc missing
    Makefile error: 1210

    or some other error , Don't get frustrated just use GOOGLE and try to look carefully in different websites many times the error occurs due to missing of some module , in that case you just have
    to install the file like in error like

    $ bc missing

    just install the module named bc

    $ sudo apt-get install bc

    it might happen that you will get a gcc compiler error , in that case upgrade your compiler to the latest version by

    first check your gcc version by

    wick@wicked:~$ gcc --version
    gcc (Debian 8.2.0-9) 8.2.0

    if version is <8.2 then use

    wick@wicked:~$ sudo apt-get install gcc-7

    Your compiler will get updated!

    upgrade your kernal to latest version

    After the kernal is upgraded your touchpad will work like it is supposed to !!!!

    Your Welcome!
    Last edited by wick; 2018-12-07 at 09:54. Reason: i have solved the problem

  5. #5
    Join Date
    solved but i'm a noob okay!
    Last edited by wick; 2018-12-07 at 11:34. Reason: Remove invalid URL

  6. #6
    Join Date
    Hi all, facing the same problem here. My question is quite simple. I believe Kali's kernel is customized and modified to fit especific pentesting standards and measurements. Updating it's kernel from a no-Kali source wouldn't strip it off this specs? Just asking, cheers

  7. #7
    Join Date
    it isn't that much more customized than a regular debian testing. There are just a few patches and none of them would affect the touchpad if that's what you're thinking.

    This may be useful:

Similar Threads

  1. Touchpad not detected
    By WavyCEO in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-07-27, 21:52
  2. Touchpad not working on Kali Linux [Can't be detected] ★
    By M0HX in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-03-06, 09:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts