Results 1 to 2 of 2

Thread: How to resolve tightvnc connect in Kali Linux 2018

  1. #1
    Join Date
    2018-Feb
    Posts
    1

    How to resolve tightvnc connect in Kali Linux 2018

    In Kali Linux (within WSL) I can connect to tightvncserver with below configure:
    Code:
    nano ~/.vnc/xstartup
    Code:
    vncconfig -iconic &
    xsetroot -solid grey
    unset SESSION MANAGER
    exec /etc/X11/xinit/xinitrc
    xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    but in Kali Linux in VMware workstation I cannot connect and I get this error message:

    Code:
    did not receive a reply possible causes include a remote appication did not send a reply the message bus Security policy blocked the reply. the reply timeout expired or the Network Connection was broken
    
    unable determine failsafe session name posible causes xfconfd isnot running dbus setup problem: environment variable $XDG_CONFIG_DIRS is set incorrectly or xfce-session is installed incorrectly
    How can I resolve this problem exactly?

  2. #2
    Join Date
    2018-Jun
    Posts
    1
    hi, i could never overcome remote desktoping with built in vncservers (grey screen with big x) and after stopping vncserver i had to restart kali due to everything i tried to open in my pc desktop was popping up on the remote vncsessions screen only and not on local desktop.
    what i found with rolling 2018.1 / 2018.2: the live system (from usb) has 'vino' built-in. what makes in settings/sharing a Screen Sharing entry. (after i installed - not live - i realized 'vino' missing - so i apt installed 'vino' and i got again screen sharing). vino is another vnc server so i can access screen (e.g. on my android phone) by vnc viewers.
    in order to switch it on i need to be connected to a network (in my case i made my android phone AccessPoint and i connected to it via wifi). when i made my pc as wifi Hotspot it was not showing up as selectable network for sharing until i entered manually the ipv4 address of the kali Hotspot (network connection editor).
    then next problem came some unknown authentication protocol when i attempted to connect. so i had to install dconf-editor and find org,gnome,desktop,remote-access / require-encryption to untick (make false). without dconf-editor from commandline:
    gsettings set org.gnome.Vino require-encryption false
    gsettings set org.gnome.Vino authentication-methods ['vnc'] (default is none)

    finally after you connect to your desktop from remote device it will ask password (should set up during allowing screen sharing), then you should see exactly the same screen on your remote device as on your local desktop. (same session)

    if in settings/sharing switch on remote login you can use ssl-clients to control kali with command line / terminal style.

Similar Threads

  1. Replies: 4
    Last Post: 2016-05-17, 15:26
  2. apt-get update Could not resolve 'http.kali.org'
    By evolition in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2014-02-20, 22:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •