Results 1 to 2 of 2

Thread: MBP 2017 very weak WIFI signal on ALL adapters

  1. #1
    Join Date
    2018-May
    Posts
    1

    MBP 2017 very weak WIFI signal on ALL adapters

    Hi!

    I just installed latest Kali 2018.2 and encountered a problem with weak wifi signal. I have two adapters, one internal Broadcom Limited BCM43602 802.11ac Wireless LAN SoC [14e4:43ba] (rev 02) and external TP-LINK 722N. The strange thing is that on BOTH adapters I have very weak wifi signal strength comparing to when I'm in macOS.

    iwconfig shows:

    Code:
    wlan1     IEEE 802.11  ESSID:"XXXXX"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 6C:70:9F:EA:FE:10   
              Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=47/70  Signal level=-63 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:181   Missed beacon:0
    
    wlan0     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
    So, I'm 7 meters from access point, and I'm only able to connect to it with wlan1, which is usb TPLINK 722N adapter. What is strange is that even being so close to AP it says that link quality is only 47/70. At the same time, internal broadcom adapter (wlan0) is unable to connect to AP at all even having the TX POWER set to 31. When I'm 1meter away from AP I'm able to connect to it using internal adapter, BUT link quality in that case is also around 40 of 70. Also internal adapter doesn't see any other wireless networks around. But when I'm booted in macOS it sees a lot of it, and signal is very good.

    What could it be? Is there something could be done with that?

    Thanks in advance for help!

  2. #2
    Join Date
    2016-Dec
    Posts
    219
    A few things:
    - Signal quality is different from one driver to another.
    - Your internal card doesn't have 31dbm, it would be more than 1 watt. It probably has 20dbm at best.
    - 47/70 or 40/70 isn't necessarily weak. Perform a speed test using iperf to confirm it with one machine being connected to the wired network and this mac connected wirelessly/. I have a very "weak" signal but it is because I'm far from my AP and it is not in an ideal location (on the floor, in a corner) but my connection works just fine.

    The driver for the internal card is probably still a work in progress and that is most likely why the signal isn't great. When there are problems, they are usually reported in dmesg.

Similar Threads

  1. Weak WiFi Signal with Resltek RTL8723be
    By Exmix in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-11-07, 12:35
  2. Replies: 6
    Last Post: 2017-09-02, 05:41
  3. wifi adapters
    By skankhunt42 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-12-29, 06:11
  4. very weak wifi signal
    By chembai in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-03-16, 11:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •