Results 1 to 1 of 1

Thread: Blank [login] screen after getting upgrade

  1. #1
    Join Date
    2018-Jun
    Posts
    1

    Blank [login] screen after getting upgrade

    Edit2: Please disregard the problem, editing the grub file fixed it. If I get it again after some time, I'll bump this thread after sufficient time has passed. Now I have a minor problem: The touchpad movements are a bit dodgy.. Wasn't like that before. USB Mouse works just fine. Is there some way I can try to fix it without risking anything else?

    My computer has dual-boot. One is windows 10, and one is kali linux. It was all running good until I had upgrades today... So since yesterday I was getting messages on like my desktop to install upgrades, and today I finally installed them. They took round about 30 minutes (more or less) on my i7 machine.. but afterwards, it wouldn't start.

    When I run kali linux OS, normally there are lines on the command-prompt alike screen and it would ask me to wait 1 min 30 secs for the boot to run.

    After upgrade, after those 1 min 30 sec, the screen would just go blank/black. I searched on youtube and the guy showed like the OS runs you just have to enter your username/password and it will take you to the desktop screen. I did that a couple of times, while the screen still remained blank, but I noticed it would flicker a bit and when I pressed laptop power button to turn it off, it took longer than before, implying that I was indeed on my desktop but it wasn't showing?

    I did different stuff with recovery mode as people said on the internet with same issues. I'm just a beginner at linux distributions I just have to use kali for some course I'm enrolled in so I don't have much knowledge of it at the moment.

    After 'dpkg --configure -a' command on recovery, my boot actually started working but it showed a few glitches/bugs- my wallpaper was white, the bar on the left was transparent and was lacking its qualities, like the fading speed, I suppose it had to do with graphics. And I was unable to decrease laptop brightness.

    There was this nomodeset thing I tried, the people said to replace nomodeset with quiet splash nomodeset when the boot takes place, I did so, after which the left bar, and brightness actually worked for a while.
    I wouldn't get those 1min 30 sec loading screen anymore, but after a wait of 2-4 mins in blank screen I would be taken to the login screen.

    I was unable to locate grub.conf file from terminal so I edited the file by going to its directory using search in linux and changing the nomodeset there as well.

    But after trying those loads of things, commands, and at last editing the grub, I'm unable to boot from there again.
    I did recovery mode, did update-grub command there, and apt-get upgrade, and booted using ctrl+x, and now I'm here. Everything seems to work here. But I just can't do that every time. Also apt-get update command in terminal is like unable to fetch the data, giving some sort of repository not allowed to do that error.

    I'm sorry for the really long post and still not direct to the problem. I hope you will forgive my lack of knowledge about kali.

    Is there any way like I'm using kali now after recovery mode and boot from there, for me to use it the same way on default boot? Is there some commands or actions I can do here that would prompt the default boot to work fine?

    Also could I repair it using live usb boot?
    Or go back to the point before the upgrade? If there are any restore points stored by default.
    Please help.

    I can possibly make a short video of what is there on screen when I run kali from recovery mode if required.

    Edit:
    Current scenario:

    It's same. I go to recovery, and even without doing anything, I press ctrl+x to boot, and it would take me to the login screen, after loading everything. But this is not happening with default boot. Also the repository thing I mentioned, it was a broken mirror link. I fixed it, but the problem is still there. And the dpkg --configure -a now does nothing.

    Btw to admins/mods: This is my 2nd acccount, I first made acccount with credentials Chic_1337 but I was not getting activation mail from it and I was unable to contact admin so I had to make a new account. So you can go ahead and delete that one..
    Last edited by Chic_1338; 2018-06-04 at 07:33.

Similar Threads

  1. Replies: 1
    Last Post: 2018-05-17, 15:53
  2. Black screen after login after upgrade/dist-upgrade
    By pendragyn in forum TroubleShooting Archive
    Replies: 16
    Last Post: 2017-03-29, 10:13
  3. Replies: 2
    Last Post: 2017-01-23, 09:48
  4. Replies: 0
    Last Post: 2016-02-21, 04:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •