Results 1 to 8 of 8

Thread: Users Cannot Login; Only Root Access

  1. #1

    Users Cannot Login; Only Root Access

    The issue i'm having with kali, is that i can no longer login as a user. I can only login as root. I can login to my users through the console, but cannot from the GUI login screen when booting the machine. To me this screams permissions, but i checked every where i could think of, and didn't see anything wrong. Does anyone have experience with this issue that could help me?

    recent changes made was that I configured a windows xp virtual machine w/ mysql server and i installed Nessus. The pc worked fine until i rebooted.

  2. #2
    Join Date
    what kind of error are you getting?

    do you mean that the user profile is not showing up, or that you get an error?

  3. #3
    hmmm, i guess my reply didn't show up....after i login to my user profile it doesn't give me an error, it just goes to the blank screen right before it goes to the desktop, but reverts back to the login screen. I can however switch to console mode, and login to my users just fine, it just won't do it during the GUI authentication process. Is there a log file somewhere where i can see what's going on after trying to login? perhaps an error is showing up there. I even tried making another user to see if it lets me login, and the same stuff happens.

  4. #4
    Join Date
    I am having basically the same issue, but in reverse. (I cant login as root anymore, but i can log in as a user). I can log into root account in terminal, but not through GUI. If i try to log in in the GUI, it logs in, then immediately goes to a white screen that says "oh no! something has gone wrong. A problem has occurred and the system cant recover. Please log out and try again". I've been running this fine for a couple weeks now, and after a restart today, this started happening. I completely re-installed, and did the updates, restarted and its doing it again. Not sure what i should do......I think it might have to do with some or one of the updates, but not sure which one.....

    EDIT: So after reinstalling several times, i think Ive found the cause of the problem. At least for me anyways.....
    When it was originally working, i changed the mouse track pad settings (adjusted sensitivity and speed) along with clicked the check boxes for enable mouse clicks with touch pad, and disable touch pad while typing. Everything would work fine until restart. Then i would get the error mentioned above....If i only click the enable mouse clicks with touch pad (the main setting i wanted changed) and nothing else. Everything still works after reboot. Not sure why this happens....
    Last edited by christstc; 2013-05-07 at 14:49.

  5. #5
    Join Date
    If you cat .xsession-errors file in your home directory you can see gnome can't write to /tmp directory

    "/etc/gdm3/Xsession: Beginning session setup...
    localuser:youruserhere being added to access control list
    openConnection: connect: No such file or directory
    cannot connect to brltty at :0
    mkdtemp: private socket dir: Permission denied"

    chmod 1777 /tmp as root to fix that.

    I'm not sure if all secuirty paranoid people agree with this solution, but that's a question to anyone here with more experience.

    Addionally I've noticed that while you can log in as a standard user, xsession generates more errors after that. I will test it in case I'm going to end up with GB size xsession-error file.


    The error log doesn't seem to grow to the infinity.

    I've checked with some other default Kali installations on other machines and it appears /tmp directory has 1777 rights as default.
    No idea why on my installation other users had no write permission. It was fairly standard install with only few tools, programs installed on the top of it.
    Last edited by Zamoysky; 2013-10-01 at 11:15.

  6. #6
    Join Date
    I had same problem when I try to login a user, the screen just blinks then goes back to login screen, and only 'root' can login,
    the cause for me is after I accidently remove my /tmp directory and mk replacement, this fix works 4 me^^
    Quote Originally Posted by Zamoysky View Post
    chmod 1777 /tmp as root to fix that.
    tnx man^^

  7. #7
    Join Date
    In my case i had a .xsession with a command that stoped working.

  8. #8
    My problem is that, after installation I cannot login with my account created during installation, it reports error : "Authentication failed" but I am sure my login information is correct, because it log me in I'm terminal. Please need help.

Similar Threads

  1. have a drop down menu list for users at login screen.
    By au10tic in forum How-To Archive
    Replies: 0
    Last Post: 2020-04-07, 07:21
  2. Segfaulting on trying to access Users in Settings
    By vaze159 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-11-30, 14:46
  3. Difference of root and standard users
    By Seeker in forum General Archive
    Replies: 2
    Last Post: 2014-10-16, 06:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts