Results 1 to 3 of 3

Thread: Wireless USB causing issues?

  1. #1

    Wireless USB causing issues?

    Hey All,

    Purchased a wireless usb adaptor and since plugging it in has been causing issues with my Kali Linux VM.

    The USB adaptor itself is a "Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter". I'm running Kali Linux 2018 (Linux version 4.15.0-kali2-amd64) and it's being run on VM WorkStation Pro 14. The host computer is Windows 10 Home.

    At first couldn't get the usb to work, realised I hadn't connected the usb to VMWare in the settings. This got the wifi working, but after a while the terminal would start hanging with any network related commands, this would include ifconfig, iwconfig. There would be no way to break it, so would have to close it, the only way to get things working again would be by rebooting the VM. I ran dmesg and it came up with some of the following errors in relation to those commands and the usb adaptor:

    Code:
     task ifconfig:1611 blocked for more than 120 seconds.
    [  484.791812]       Not tainted 4.15.0-kali2-amd64 #1 Debian 4.15.11-1kali1
    [  484.791814] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
    
    
    
    
    [  197.703262] rtl_usb: reg 0x4, usbctrl_vendorreq TimeOut! status:0xffffff92 value=0x631b25f6
    For the life of me can't figure out why the adaptor is causing these issues. After a few restarts it seems like the wifi won't find any networks and Kali says that the network manager needs to be running, though can't run the command to start/restart/stop because the terminal will hang. Tried searching for related issues in regards to the terminal hanging, thought it might have been a ram related issue so assigned more to the VM and restarted but still having the same issues.

  2. #2
    Join Date
    2016-Dec
    Posts
    306
    I may have used this chipset in the past but don't remember having issues with it. Try updating the kernel to see if it's any better. Current version is 4.16:
    apt update
    apt dist-upgrade
    reboot

  3. #3
    Thanks for your help, tried that but still having the same issues. Might invest in a new adaptor (one from the list that are recommended) and see how I go.

Similar Threads

  1. Intel Wireless Issues
    By Booshotti in forum TroubleShooting Archive
    Replies: 9
    Last Post: 2017-02-13, 20:17
  2. Wireless USB issues
    By deanfourie in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-05-26, 15:23
  3. wireless connection issues
    By NewtoLinux in forum General Archive
    Replies: 4
    Last Post: 2013-10-08, 17:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •