Results 1 to 4 of 4

Thread: ALFA AWUS036ACH not finding any networks

  1. #1
    Join Date
    2018-Jun
    Posts
    1

    ALFA AWUS036ACH not finding any networks

    Hi, I just got the ALFA AWUS036ACH usb wireless adapter with the drivers installed on my Kali box. It shows up in iwconfig and ifconfig as wlan0 but on the network manager gui, there is no wireless networks shown.

    iwconfig
    lo no wireless extensions.

    wlan1 IEEE 802.11 ESSID:"MFD5GHz"
    Mode:Managed Frequency:5.745 GHz Access Point: 20:C0:479:57:52
    Bit Rate=390 Mb/s Tx-Power=22 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementn
    Link Quality=52/70 Signal level=-58 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:10 Missed beacon:0

    wlan0 IEEE 802.11 ESSIDff/any
    Mode:Managed Access Point: Not-Associated Tx-Power=18 dBm
    Retry short limit:7 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff

    eth0 no wireless extensions.

    wlan0 is my wireless adapter.

    Any help on actually being able to find networks with my adapter? I have tried searching before and let it run for a while and it does not find anything despite there being around 20-30 near me.

    Thanks

  2. #2
    Join Date
    2013-Apr
    Location
    Kali forums
    Posts
    796
    First thing I'd check is the output of dmesg, and journalctl...see if there are any errors there involving your card.

    Will the card go into monitor mode & do packet injection?

  3. #3
    Join Date
    2013-Jul
    Posts
    41
    My 2nd day with AWUS036ACH, I've had issues. Here is what I've done to fix " Not seeing networks" .

    First off , I grabbed drivers from github, https://github.com/kimocoder/rtl8812au . Not by " apt install realtek-rtl88xxau-dkms " . I had issues with whatever driver is in Kali repo .

    There is a great post already within these forums found here https://forums.kali.org/showthread.p...ght=AWUS036ACH . Found within that thread , Post #23 .
    git clone https://github.com/kimocoder/rtl8812au
    cd rtl8812au
    make && make install

    ip link set wlan0 down
    iwconfig wlan0 mode monitor
    ip link set wlan0 up

    airodump-ng -i wlan0
    Those commands got me up and going , Then turned last bit into a small bash script ( You might be at wlan0 ) .
    ip link set wlan1 down
    iwconfig wlan1 mode monitor
    ip link set wlan1 up
    iwconfig wlan1 txpower 40
    iwconfig | grep wlan1
    Now airodump is listing networks, and ones I have never seen!

    What does dmesg have to say ?
    dmesg | grep -i rtl

  4. #4
    Join Date
    2018-Aug
    Posts
    6

    Not seeing any APs??

    Quote Originally Posted by hightech316 View Post
    My 2nd day with AWUS036ACH, I've had issues. Here is what I've done to fix " Not seeing networks" .

    First off , I grabbed drivers from github, https://github.com/kimocoder/rtl8812au . Not by " apt install realtek-rtl88xxau-dkms " . I had issues with whatever driver is in Kali repo .

    There is a great post already within these forums found here https://forums.kali.org/showthread.p...ght=AWUS036ACH . Found within that thread , Post #23 .


    Those commands got me up and going , Then turned last bit into a small bash script ( You might be at wlan0 ) .


    Now airodump is listing networks, and ones I have never seen!

    What does dmesg have to say ?


    So I have done everything above and here is my dmesg..
    [ 899.834927] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1051.641889] device wlan0 entered promiscuous mode
    [ 1053.441926] device wlan0 left promiscuous mode
    [ 1214.888125] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1529.894390] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1844.968417] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2151.956621] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2232.079380] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2240.385531] device wlan0 entered promiscuous mode
    [ 2344.516655] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2381.529719] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 2477.936556] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    root@kali:~# dmesg |grep -i rtl
    [ 443.040153] usbcore: registered new interface driver rtl88xxau


    Any help?

Similar Threads

  1. ALFA AWUS036ACH Not seeing Wireless Networks
    By morpheus83uk in forum Kali Linux TroubleShooting
    Replies: 10
    Last Post: 2018-06-01, 12:37
  2. Alfa AWUS036ACH (brand new) can only see 5 networks on Kali?
    By Leijonasisu in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-08-01, 20:56

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •