I am dual-booting with Windows and recently got rid of an Ubuntu installation. I now have Kali's version of grub as my bootloader but it will not, no matter what I do, remember the last chosen entry, which is annoying when I have to do other work in Windows. I'd rather not set grub to never time out but I may have to. Is this a common issue with Grub from Kali, or am I missing something else? I never had this issue with other Linux distros.

DEFAULT=saved # for kicks, since grub_default wasn't working
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

I've run grub-mkconfig and update-grub, and even changed "grub_default" to 2 temporarily and did a git diff with a copy to make sure update-grub was doing something.

The only settings I've touched are the .*DEFAULT ones, and a background image in /usr/share/desktop-base/grub_background.sh (grub default was also not working before that)

Help plz?