Results 1 to 2 of 2

Thread: Raspberry pi 3 ssh remote unlock via dropbear fails with "resource busy"

  1. #1
    Join Date
    2013-Jun
    Posts
    4

    Raspberry pi 3 ssh remote unlock via dropbear fails with "resource busy"

    Hi All,

    As per the $subject of this post, I've hit an issue after following the article here: https://www.kali.org/tutorials/secure-kali-pi-2018/

    In short almost everything works, the pi sits with dropbear happily listening, I can SSH to it to no problem and get prompted for the unlock password of the LUKS encrypted partition; so far so good...

    After entering the correct password however, `/dev/mmc0p2` fails to mount with the error "resource busy", at which point the boot into kali fails and it drops to a recovery shell,

    Has anyone encountered this issue before, could it be the SD Card ? (32GB EVO Plus 87MB/s w, 91.5MB/s r);

    I'm going to try a couple differing SD Cards and see if I can workaround this issue if indeed it is hardware storage based, I'll post back with the results in the mean time if anyone knows of a potential area to explore other than swapping out hardware in the hopes something works I'm all ears.

    (Yes, I've used the forum search but could not find any similar threads hence posting this).

  2. #2
    Join Date
    2014-Feb
    Posts
    210
    It could be the sdcard. I'd definitely run through the instructions again. I've done it on 4 different sdcards and haven't had it drop me to a shell because it couldn't mount the partition. I'd suggest double checking on the machine you made the sdcard on - are you sure there are no typos made?

Similar Threads

  1. installing from cd made from mini.iso fails at "select a mirror"
    By Lew Rockwell Fan in forum Installing Archive
    Replies: 1
    Last Post: 2016-01-21, 10:43
  2. Replies: 1
    Last Post: 2015-09-26, 22:07
  3. Unable to connect to the Internet."apt-get update fails"
    By 9h05t in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-07-14, 22:50
  4. "nexus-fastboot oem unlock" fails with Nexus 7 2012 wifi
    By pmellen in forum Installing NetHunter
    Replies: 0
    Last Post: 2015-07-06, 06:41
  5. installing from vm live to usb "fails"?
    By schutzhund3 in forum Installing Archive
    Replies: 3
    Last Post: 2013-05-14, 22:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •