Results 1 to 2 of 2

Thread: Old PC will not use kernel 4.15 or higher

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2018-Jul
    Location
    Las Vegas
    Posts
    1

    Old PC will not use kernel 4.15 or higher

    Hello,
    I have two older laptops: HP2000 with AMD E-300 and HP G6 with Intel i3.

    I've tried compiling kernel 4.15, 4.16, and 4.17 on these laptops. Always fails. I am looking for a way to update the kernel in Kali to 4.14.56 (and newer when released).

    Please, before flaming me for "this question has already been answered", I've already spent many hours trying to get the newer kernels to work. Always fails. I don't know why newer kernels fail, but always do during make deb-pkg. I've asked in other forums and have not been able to solve my kernel issue. Solution would be to replace my ancient technology, but these laptops are paid for.

    I use Kali in VMWare. Tried downloading 2018, tried the VMWare premade image. Both failed. Have 2017.2, works great. The change logs on kernel.org show many improvements and would like to apply 4.14.56 to the 2017.2 Kali install.

    Usually get asked for debug information. Not sure how to do that. Any help would be appreciated.

  2. #2
    Join Date
    2018-Sep
    Posts
    6
    Linux in it's self has always been friendly towards Older and Newer Devices! I personally have used older Machines for throw away, testing purposes and any flavor of Linux has always been fine.
    Kali 4.* Kernel is based on Debian Jessie. here are 2 Links:
    1)http://https://www.debian.org/releas...h02s01.html.en #The Official Debian Jessie Hardware Support Page which I don't see any issues with your Hardware

    2)https://www.interfacett.com/blogs/in...in-kali-linux/ #Graphic interface for Synaptic pm for Kali.

    Synaptic will make it easy for you to find the correct Kernel Headers that support your Devices or other Dependencies that may pop up.
    Hope this was helpful.

Similar Threads

  1. Changing MAC Address Issues With 4.14 Kernel (4.13 Kernel is fine)
    By schaeferhund1 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2018-03-09, 23:03
  2. How to Set Your Wi-FI Card Tx Power Higher Than 30dbm
    By Nick_the_Greek in forum How-To Archive
    Replies: 23
    Last Post: 2018-02-02, 08:06
  3. Replies: 12
    Last Post: 2017-03-05, 03:28
  4. Changing/forcing Wireless Card TXPOWER rate higher?
    By Leijonasisu in forum General Archive
    Replies: 5
    Last Post: 2014-09-16, 15:15
  5. Replies: 6
    Last Post: 2014-01-15, 21:00

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •