Results 1 to 3 of 3

Thread: Dual boot with windows 10

  1. #1
    Join Date
    2018-Jul
    Posts
    3

    Dual boot with windows 10

    I did try to do some searching but I"m not finding specifically how to resolve this.

    So I have windows 10 on one partition and I created another partition of about 100GB for Kali. I copied the ISO onto a USB stick and installed it.
    When I start my computer, windows takes me to a blue screen and asks me to choose WIndows 10 or the button below it which says "Debian Complete the installation"
    Why does it say complete the installation when the installation should be done?

    With some serious arm wrestling and going in and out o my BIOS and clicking on the hard drive under the boot devices after about 10-12 boots (ridiculous) I was presented with the menu.
    I was able to get into Kali. I thought I remembered the password for root username. I tried root and toor and neither of those worked. I tried what I thought was the pw I created. Some how after typing a lot of times, I managed to get all the way into the platform. Now, however, I'm not able to get in. The pw just doesn't work. What can I do to get logged in?

    FYI when I installed Kali, at one point it asked about the dual boot. It asked where I wanted to install. I believe it said windows master boot. So it wrote it here. Was this the grub installer? I get a black screen with white text when trying to login saying a file is missing for windows but I can hit escape and get back to the blue screen with the 2 buttons. (one for windows 10 and the other for complete installation)

    Can someone direct me on what to do? I'd like to turn on my computer and be presented immediately with the dual boot menu to decide which operating system to you.

    Thank you.
    Kalitester

  2. #2
    Join Date
    2018-Jul
    Posts
    3

    Unhappy

    I have read the sticky on the dual boot with windows 7. I don't see any solution to my problem in the thread. I have watched numerous videos on what to do.
    I tried this what is below and it could not find windows. My computer has 8 partitions. sdc1 Recovery (523mb) sdc2 filesystem 105mb, sdc3 microsoft reserved 17mb, sdc4 filesystem 392GB, sdc5 microsoft windows recovery environment, sdc6 bios boot 1mb, sdc7 ext4 linux filesystem, sdc8 swap 7.5GB, free space 1.1MB

    I performed the commands below. when it did the grub install, there was no message stating that it found the windows 10 system. I noticed in the video i watched that he received a message that the windows was found and this appears in the boot menu when the computer starts. Not for me...

    root@kali:~# sudo mount /dev/sdc7 /mnt
    root@kali:~# sudo mount --bind /dev /mnt/dev &&
    >
    > sudo mount --bind /dev/pts /mnt/dev/pts &&
    > sudo mount --bind /proc /mnt/proc &&
    > sudo mount --bind /sys /mnt/sys
    root@kali:~# sudo chroot /mnt
    root@kali:/# grub-install /dev/sd7
    Installing for i386-pc platform.
    grub-install: error: cannot find a GRUB drive for /dev/sd7. Check your device.map.
    root@kali:/# grub-install /dev/sdc7
    Installing for i386-pc platform.
    grub-install: warning: File system `ext2' doesn't support embedding.
    grub-install: warning: Embedding is not possible. GRUB can only be installed in this setup by using blocklists. However, blocklists are UNRELIABLE and their use is discouraged..
    grub-install: error: will not proceed with blocklists.
    root@kali:/# grub-install /dev/sdc
    Installing for i386-pc platform.
    Installation finished. No error reported.
    root@kali:/# update-grub
    Generating grub configuration file ...
    Found background image: /usr/share/images/desktop-base/desktop-grub.png
    Found linux image: /boot/vmlinuz-4.15.0-kali2-amd64
    Found initrd image: /boot/initrd.img-4.15.0-kali2-amd64
    There should have been a message here saying found WIndows 10 on sdc4 - there was no message
    WARNING: Failed to connect to lvmetad. Falling back to device scanning.
    done
    root@kali:/#


    Can someone explain why it doesn't find my windows and fix the dual boot?

  3. #3
    Join Date
    2018-Jul
    Posts
    3
    I have run the commands from Kali live. My Kali ext file system is in sdc7.

    fdisk -l
    sudo mount /dev/sdc7 /mnt
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys
    sudo chroot /mnt
    grub-install /dev/sdc
    Press CTRL+D
    sudo umount /mnt/dev

    After running the grub-install, it says there are no problems with the installation. There is no message stating that is FOUND WINDOWS 10. It did not find it. There is no grub menu when I reboot my machine.....This is really lame and frustrating...
    sudo umount /mnt/proc
    sudo umount /mnt/sys
    sudo umount /mnt

Similar Threads

  1. Dual boot Kali/Windows 7 mbr EUFI in Legacy, no EFI boot partition
    By Dr.Tautology in forum Installing Archive
    Replies: 0
    Last Post: 2015-08-07, 15:08
  2. Dual Boot Kali Linux with Windows 8.1 (UEFI and SECURE BOOT)
    By sentostv in forum Installing Archive
    Replies: 2
    Last Post: 2015-01-01, 02:53
  3. Making Windows 7 default boot on dual boot install
    By depth-10 in forum Installing Archive
    Replies: 5
    Last Post: 2013-05-26, 23:36

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •