Results 1 to 7 of 7

Thread: apt-get problems

  1. #1
    Join Date
    2015-Aug
    Location
    Micjigan
    Posts
    9

    apt-get problems

    I am running kali 2018-2 on lenovo T420. When I try to update and upgrade I get apt-get is locked.
    I think I tracked down the problem. It looks like kali 2018 as a auto update and download now. kali is getting just like windows, I don't like it.
    So what I would like to know is their a way to disable the auto update and upgrade, So i can do it when I want to have it done.
    thank you all
    renny

  2. #2
    Join Date
    2016-Dec
    Posts
    328
    It's from Debian and Ubuntu has had it for a long time. Search how to disable aptd.

  3. #3
    Join Date
    2015-Aug
    Location
    Micjigan
    Posts
    9
    Thank you mister_X Seeing I don't know what I an doing here, this is what I found

    tan@ubuntu:~$ sudo systemctl stop apt-daily.timer
    tan@ubuntu:~$ sudo systemctl disable apt-daily.timer
    tan@ubuntu:~$ sudo systemctl disable apt-daily.service
    tan@ubuntu:~$ sudo systemctl daemon-reload

    Is this what you was talking about.
    Thank you
    Renny

  4. #4
    Join Date
    2018-Jul
    Posts
    6
    Well, you can try a few things, from the read out you're running as a user so you could try typing in

    sudo su

    which will give you the # prompt meaning you're set to root, then you don't need to type in sudo before every command and it makes everything a lot faster.

    Next I would suggest just trying to type in apt and not apt-get as in apt update

    You can also try to clean apt with

    apt clean

    and then from there try

    apt update
    apt upgrade -y
    apt dist-upgrade -y
    apt autoremove

    and see how that goes

  5. #5
    Join Date
    2015-Aug
    Location
    Micjigan
    Posts
    9
    apt update
    apt upgrade -y
    apt dist-upgrade -y
    apt autoremove that does nothing, what was was asking was will the command that i Found will disable the auto download.

    t
    The commands are
    systemctl stop apt-daily.timer
    systemctl disable apt-daily.timer
    systemctl disable apt-daily.service
    systemctl daemon-reload

    Will the above commands disable the auto download?

  6. #6
    Join Date
    2018-Jul
    Posts
    6
    It should but I would think stopping systemctl would disable your GUI so you would have to boot and at the login screen before logging in, hit F2 or something, maybe F4? it should boot into terminal, from there you can login, and then type out those commands as follows

    # sudo su
    # cd /bin/bash
    # systemctl stop apt-daily.timer
    # systemctl disable apt-daily.timer
    # systemctl mask apt-daily.service
    # systemctl daemon-reload
    # reboot

    Once you boot back up, you should be golden

  7. #7
    Join Date
    2015-Aug
    Location
    Micjigan
    Posts
    9
    Thank you very much
    renny

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •