Results 1 to 4 of 4

Thread: Configuring more than one wifi to connect automatically in RPi0z with Kali Linux Re4son

  1. #1
    Join Date
    2018-Aug
    Posts
    3

    Configuring more than one wifi to connect automatically in RPi0z with Kali Linux Re4son

    Hi all,


    I am new to kali linux and i would like some help with the following. I have already searched a lot but haven't found something to assist me unfortunately. I have bought a RPI0w and have installed in a sd card the kali linux build from Re4son.
    ARMEL (Pi 1/Zero/Zero W) https://whitedome.com.au/re4son/down...-armel-re4son/
    (SHA1: 7d1e7cc52c662dff7d1ea6e2aedc3c8f8a16a78a))


    What i am after is for the Pi to be able to automatically connect to various WiFi networks (not simultaneously of course), provided that i have stored in advance the wifi credentials. Please note:
    I have already configured my interfaces file as per the below for 1 wifi network and it is working fine, but what i am really after is to somehow store a list of known WiFi networks (and their credentials) and connect to them automatically each time my Pi finds them. As an example, with the following interfaces config, my Pi automatically connects to my home's WiFi mentioned below (myssid_1, mypass_1), but how can i configure it to connect automatically to my office's wifi (myssid_2, mypass_2) as well, when i boot it there, without having to manually change the wifi credentials each time i change location?


    I have actually managed to achieve this only with a Raspbian Stretch in a different sd card, by configuring the wpa_supplicant.conf file with {Network 1}, {Network 2} etc, but this approach doesn't seem to work under the Kali linux distribution. Any help (with some details if possible please!) would be highly appreciated!


    Related lines in "/etc/network/interfaces" in Kali linux (working for 1 wifi)


    auto lo
    iface lo inet loopback


    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid <myssid_1>
    wpa-psk <mypass_1>


    Thank you in advance!

  2. #2
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    192
    Hi balarinios,

    The easiest way is to use the "kalipi-config" tool. Those images should come with it pre-installed. If not, you can get it here:

    https://github.com/Re4son/RPi-Tweaks/tree/master/kalipi-config

    Just go to "network options" and set up your wifi networks. You can simply add each network and it should connect automatically next time you are in range.

    Hope that helps,
    Re4son
    ----------------------------------------
    https://re4son-kernel.com
    - - - - - - - - - - - - - - - - - - - - - -
    Check out "Sticky Fingers Kali-Pi":
    https://re4son.com/kali-pi

    Now with mana-toolkit and more goodies!

  3. #3
    Join Date
    2018-Aug
    Posts
    3
    Thank you very much re4son for the quick reply! I will try it out tonight. By the way, very good work with the Kali linux image! :-)

    Kind regards,
    Balarinios

  4. #4
    Join Date
    2018-Aug
    Posts
    3
    Thanks a lot Re4son, Kalipi-config tool wasn't pre-installed but after installation, i was able to configure all my WiFi networks, worked perfectly!

Similar Threads

  1. Kali Linux won't connect to my Wifi
    By djmedzy in forum General Archive
    Replies: 0
    Last Post: 2015-08-15, 04:25

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •