Results 1 to 4 of 4

Thread: cant see available wifi networks with ra 3070 chipset wifi usb adapter

  1. #1
    Join Date

    cant see available wifi networks with ra 3070 chipset wifi usb adapter

    Hello I am running kali2.0 on virtualbox
    I have installed ra3070 wireless adapter through usb. Device can be seen and listed in usb devices.
    I installed the driver throguth apt-get install firmware-ralink

    I tried multiple solutions including manually compiling the drivers however I still cant see the available networks. I also tried increasing tx pwer to 30dBm but no change.
    Any help is appreciated. I want to use the adapter for wifi tools. I can put it in monitor mode with airmon-ng and start monitoring but no ssids are displayed. Help pls

    COmmand outputs are as below:

    root@kali:~# lsusb
    Bus 001 Device 003: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

    root@kali:~# dmesg | grep 3070
    [ 6670.612189] usb 1-1: New USB device found, idVendor=148f, idProduct=3070
    [ 6671.499622] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 3070, rev 0201 d

    root@kali:~# iwconfig
    lo no wireless extensions.

    wlan0 IEEE 802.11 ESSIDff/any
    Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
    Retry short long limit:2 RTS thrff Fragment thrff
    Encryption keyff
    Power Managementff

    root@kali:~# iw dev
    Interface wlan0
    ifindex 3
    wdev 0x100000001
    addr ca:c4:61:ea:44:de
    type managed
    txpower 20.00 dBm

    oot@kali:~# airmon-ng start wlan0

    Found 2 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to run 'airmon-ng check kill'

    PID Name
    506 NetworkManager
    651 wpa_supplicant

    PHY Interface Driver Chipset

    phy1 wlan0 rt2800usb Ralink Technology, Corp. RT2870/RT3070

    (mac80211 monitor mode vif enabled for [phy1]wlan0 on [phy1]wlan0mon)
    (mac80211 station mode vif disabled for [phy1]wlan0)

  2. #2
    Join Date
    Kali forums
    Well, I've always found wireless work to be problematic within a VM. But if you can get the card into monitor mode, airodump-ng should work. Do you get any output when running airodump-ng? Will the card do packet injection?

  3. #3
    Join Date
    If you've compiled drivers and installed them,I would recommend to rebuild the VM, you most likely downgraded your drivers which led to issues. Usually, the only thing you have to do after a firmware install is to reboot the system.

    Just FYI, Kali 2.0 is not supported anymore (it hasn't been supported in years), download the VM of the current version of Kali and try again (with just the firmware this time)

  4. #4
    Join Date
    The Kali im using is 4.15.0 kernel which is 2018 disb. I was wrong about 2.0 sorry about that.
    Monitoring mode works and I found a workaround to do injection make it work, here is how.
    First I kill associated processes with ra3070 using airmon-ng check kill then start the card in monitor mode and start airodump-ng. No nw pops up. Afterwards i re-plug the usb adapter and repeat this process. IT starts to work then. Kinda weird but works

    root@kali:~# airmon-ng --verbose

    No LSB modules are available.
    Distributor ID: Kali
    Description: Kali GNU/Linux Rolling
    Release: kali-rolling
    Codename: kali-rolling

    Linux kali 4.15.0-kali2-amd64 #1 SMP Debian 4.15.11-1kali1 (2018-03-21) x86_64 GNU/Linux
    Detected VM using lspci
    This appears to be a VirtualBox Virtual Machine
    If your system supports VT-d, it may be possible to use PCI devices
    If your system does not support VT-d, you can only use USB wifi cards

    K indicates driver is from 4.15.0-kali2-amd64
    V indicates driver comes directly from the vendor, almost certainly a bad thing
    S indicates driver comes from the staging tree, these drivers are meant for reference not actual use, BEWARE
    ? indicates we do not know where the driver comes from... report this

    X[PHY]Interface Driver[Stack]-FirmwareRev Chipset Extended Info

    K[phy0]wlan0 rt2800usb[mac80211]-0.36 Ralink Technology, Corp. RT2870/RT3070

Similar Threads

  1. WiFi adapter sees networks but can't connect to one
    By Dante Monroe in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2023-02-02, 18:18
  2. USB Wifi Adapter AC1200 EW7822UAC (chipset rtl8812au)
    By Floo in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-10-28, 17:26
  3. How i use wlan1 (external wifi adapter) to connect to networks?
    By milestone in forum NetHunter General Questions
    Replies: 6
    Last Post: 2016-04-09, 19:59
  4. Replies: 0
    Last Post: 2015-09-30, 12:09
  5. Kinamax TS-9900 3070 chipset
    By flyinghaggis in forum General Archive
    Replies: 3
    Last Post: 2013-11-23, 03:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts