Results 1 to 8 of 8

Thread: Kali linux stucked in boot loading after dist-upgrade 4.17.0

  1. #1
    Join Date
    2017-Nov
    Posts
    13

    Kali linux 2018.2 after dist-upgrade 4.17.0---->Display manager gdm3 not working

    So, is almost 10 months that I'm using kali linux every day but I'm still noob when i need to fix something.

    Last night after some days of update notifications, I decided to run apt-get update and apt-get dist-upgrade.

    Then turned off. This morning sadly my kali in dual boot with windows doesn't boot, it's stucked here

    https://ibb.co/jLfOT9

    in recovery mode is stucked here

    https://ibb.co/cWVe1U


    (Just ignore the wifi card firmware missing and Acpi bios error, always got them, never been a problem)

    Notebook:
    Intel i7 7700 HQ
    integrated graphic card + Nvidia 1050ti (never used coz i gave up installing nvidia drivers in the 2017)
    16 gb ram
    80gb of disk space -15gb still free


    I'm almost sure is always the same problem: is the nvidia drivers even if I didnt touch them


    In the grub params I have set : nomodeset quite splash

    like someone here in forum suggested me the first time i got this problem months ago, then I also tried nouveau.nomodeset=0 looking in the last threads.

    I have just got this problem so I'm still working on it, but any advice or fix is apreciated


    Ask me everything you need to know
    Last edited by Hexe; 1 Week Ago at 10:52.

  2. #2
    Join Date
    2016-Dec
    Posts
    247
    I guess your best bet is to try booting the latest weekly ISO to see if it works. If it does, then back up the data (check out clonezilla) and reinstall kali. There doesn't seem to be anything special other than the error with acpi and ath10k (the latter can probably be solved by installing the firmware, should be something like firmware-atheros, just search for "firmware atheros" with apt).

  3. #3
    Join Date
    2017-Nov
    Posts
    13
    so seems, i can still run it in terminal mode. Almost confirming is something related to the graphic card drivers, so I installed lightdm instead of gdm3 but didn't work, i need to read what they changed with the last update to figure a fix

    Checking the journalctl logs. Soon I will post the errors



    Edit:

    Ok so, ignoring acpi error and atheros firmware which i m sure aren t the problem (i always got them)

    here the first weird red error in the logs:

    https://ibb.co/hCybY9

    i don't like it.. but still thinking isn't the problem


    And now after lightdm installation
    maybe the problem

    https://ibb.co/cx9iD9

    I will re-use gdm3 to see logs asap
    Last edited by Hexe; 1 Week Ago at 22:57. Reason: wrong screenshot

  4. #4
    Join Date
    2017-Nov
    Posts
    13
    And btw thank you misterX it will be the last thing i will try.. to many configurations setted on my kali, i cannot lose them

  5. #5
    Join Date
    2017-Nov
    Posts
    13
    So i make a new post to be clear:

    Here what exactly freeze my kali boot------>gdm3


    is a loop

    https://ibb.co/dNCWGU
    https://ibb.co/d7YtVp
    https://ibb.co/jGgrGU
    https://ibb.co/bYUNO9

  6. #6
    Join Date
    2017-Nov
    Posts
    13
    Here the xorg.0.log

    https://ibb.co/k9ghap
    https://ibb.co/cbFKMU



    Here the result of X command:

    https://ibb.co/h79h89

    i tried something like:
    dpkg-reconfigure gdm3
    service gdm3 start


    and now i'm going to looking inside the xorg configuration




    Maybe the firmware i915/kbl_dmc_ver1_04.bin

    after some work i got this in the boot loading

    https://ibb.co/c9dqd9



    I guess some problem with the capability of restore diplay registers?
    Last edited by Hexe; 1 Week Ago at 11:51.

  7. #7
    Join Date
    2017-Nov
    Posts
    13
    Still looking for a fix.

    Here the 2 errors I found with xorg:

    X -configure

    FATAL: module fbcon not found

    https://ibb.co/keOn89


    Meanwhile in the xorg.0.log


    Fatal server error:
    Cannot run in framebuffer mode. Please specify bus IDs for all framebuffer devices

    https://ibb.co/fGx30p



    Reading logs, this time aren't nvidia drivers, instead is the integrated intel graphic card having some isssue (i915)

    i tried to boot something like vga=normal in boot params.. idk how to fix the framebuffer error

    And why modprobe isn't finding the right module?

    I don't think my hardware has been damaged meanwhile i was sleeping, also windows is correctly working on the same machine, what this dist upgrade modified about intel modules/drivers?

    I'm noob just trying to learn more as possible to fix my kali, hoping in some linux master coming here to help me

  8. #8
    Join Date
    2017-Nov
    Posts
    13
    Update:

    Found the missing kaby lake firmware
    i915/kbl_dmc_ver1_04.bin

    on my kali there was only the 1_01 version, so i added it. but it didnt help.


    Quote Originally Posted by Mister_X View Post
    I guess your best bet is to try booting the latest weekly ISO to see if it works. If it does, then back up the data (check out clonezilla) and reinstall kali. There doesn't seem to be anything special other than the error with acpi and ath10k (the latter can probably be solved by installing the firmware, should be something like firmware-atheros, just search for "firmware atheros" with apt).

    At the end, i gave up. After a small /home backup, i tried to install a 2017.3 i had on my usb. Everything went fine. When i tried dist upgrade again. The bug happened again.

    So, i tried only apt-get update and apt-get upgrade to check if was the dist-upgrade bugging my distro( changing dependencies with new versions of packages missing something) , and it worked a bit, i mean the distro boot normally, was able to start with the graphic interface, but idk why the terminal wasn't working, click on it, shurtcut etc etc no way to open it. (Not surprised)

    There is no way I can upgrade my distro?

    I tried to install the 2018.2 4.15.0 and also the E17 version, which worked in live mode, but both gave me error during installation saying the image on the usb was corrupted ( i tried 2 different usb and 2 different iso writers).

    Maybe just a case, both usb or iso had problems. Tomorrow i'm going to try again as soon i will be at home.


    Atm seems my clevo assembled notebook cannot work with the last kali realese.

Similar Threads

  1. Kali rolling 17.1 stauls during loading process after dist-upgrade
    By E.T.II in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-09-22, 20:03
  2. Replies: 5
    Last Post: 2017-07-13, 11:30
  3. vboxguest module not loading after dist-upgrade
    By fsociety[00]dat in forum General Archive
    Replies: 1
    Last Post: 2017-03-12, 12:00
  4. Replies: 16
    Last Post: 2017-01-25, 01:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •