Results 1 to 7 of 7

Thread: asus x756u installation probleme

  1. #1
    Join Date

    asus x756u installation probleme

    Ive got a Asus x756u with 6gb of ram, intel i5, Nvidia 940mx, and a 1 tb HDD running windows 10 64 Uefi.

    I want to dual boot windows and kali linux but I'm having one priticular issues i don't know if its linked to the bios and uefi set up or something else
    ive already set up everything (make a 60 GB free space ,disable secure boot, disable fast startup ... ) anyway after the bootloader popup i choose the graphical install after that i complete the installation normally (if i have to mention that the mousepad isn't working during the installation and thats not causing any problem to me im just using my keyboard to install kali linux).
    well everything goes fine when its time to chose the partition i used guided that is doing all the work for the new users and i tried also manual and then i create a new partition for the swap area and i give it +5 GB. till now all is good but when its finish the installation and asking me to remove the media (USB or DVD) to reboot i do that and then nothing show up i mean i press esc to enter to the bios settings to choose the kali linux but i find nothing their. also when i get back to windows and check if anything happen to the hard drive i found that the partitions i did during the installation are made and all the space is taken i mean its all used ( view image bellow).

    asus prb.JPG
    ive tried so hard before i post here and im very stuck over here

    PS: - i tried with kali linux 2017.3 2018.1 2018.2 and i used win32manager, poweriso, rufus and even unetbooting but nothing works
    - when i use kali live it works fine with no problem on it even the mousepad works fine
    - those are some images of my bios settings

    IMG_1129.jpg IMG_1130.jpg IMG_1131.jpg

    Thank you for reading this post and i'll be very grateful if anyone can help me solve this out

  2. #2
    Join Date
    Try using DD-mode instead of downloading. Your issue is caused because of missing Firmware part that Kali dont even need. You dont need to do it as graphical mode.

    Using dual boot is not very good idea anyway. if you get something wrong (like changing they partitions) it can get both of them cracked.
    Changing hard disk takes under 1min to do even on laptops and you can get them for free because peoples dont save them after they broke they laps. They are not so expensive at stores, just check from internet

  3. #3
    Join Date
    firstly thank you for your answer greenmile
    i did what you proposed i used dd-mode and i install kali linux 2018.3 and i used simple install mode not the graphical i mean
    well i made all the steps
    here is the partitioning step
    Attachment 3120
    then i waited till the installation complete and asking to remove media for reboot the computer
    Attachment 3121
    after that the same thing happened i mean windows started without kali or the bootloader
    what i did next is lunching the live kali then i used the "blkid" command to show me all the partitions of this computer, well this is the result
    Attachment 3122
    you may notice that everything goes fine lol but not fine i mean if you compare the partitions of the ext4 and the swap during the installation and using the command you'll find that they match
    sda7 for the ext4 which stand for the kali linux and the sda8 for the swap.
    you can also see that here with a graphic mode, here is all the partition of my hard drive for windows i have two partitions C for the system and D. and it's shown that kali is installed i mean this partition it used about 10 or 11 GB of kali linux system files.
    Attachment 3124
    well then i thought there was something went wrong with the bootloader i mean if the kali linux grub bootloader is missing then i tried to fix that i did the following command in the live kali
    Attachment 3123
    this is not my computer but all it was the same for me but instead of windows 7 i had windows 10.
    well after all that it didn't work and im feeling frustrated.

    for your second suggestion, do you mean that i need to buy another hard drive and install kali linux on it and use it normally? and if it's the case then i don't know if my laptop can use two hard drives?
    i already have one it's a 120GB seagate it's a HP HEWLETT PACKARD
    i hope you find out something i didnt think of and find a solution for me
    Last edited by renic; 2018-09-01 at 11:40.

  4. #4
    Join Date
    Hi! For some reason I cant open your links.

    This kind of issues are usually support based. That means either you usb or motherboard is not supporting.
    So.. Is your usb set as FAT32? How about motherboard? Is it FAT32 or NTFS? Kali works on NTFS too, but after some time there can be issues with some programs.
    DD-mode is required as Kali ISO is not supporting others. As you can see from other pages and - users they all informs to use FAT32. If you downloaded ISO from and used Rufus, there should not be any problems at all.
    If you partitioned usb as FAT32 and Disk is as so too, I think the only reason is, something went wrong with partition.

    If you are still considering dual... think twice if you cant get Kali working at first place. Too many things can go wrong with partitioning and resizing is the worst of them.

  5. #5
    Join Date
    BTW!!! If you like using Kali, the BEST AND SECUREST is using it as live. Only crab part is, basic ISO-live is not practical because you have to download everything you need always again when you start it and you cant safe anything.
    Bypassing that, you can make Updated/Upgraded ISO version by yourself, just follow instructions from Docks of Kali then make that Live AND Persistence. Now you have FULL Kali-Linux with option of downloading staff to it. Best part is that anything you download is on "sandbox" like partition, so you Kali is safe at any time and your (16 to 32 or bigger) USB drive moves with you anywhere at cost of almost nothing!!!

  6. #6
    Join Date
    thank you so much for your help
    i did find a solution for my issue and here is what i did

    1- i used EaseUs Partition to format the partition where kali and the swap are
    2- i reinstall kali using the same steps until i got to the partitioning part
    3- instead of using guided- use the largest amount ... or choosing manual and giving like in my case 58 gb for kali and 6GB for Swap i did:
    4 - i make 4 partitions for the partitioning, as i said i used 64 gb, so:
    4.1 first time click on create new partition and give it 2GB and in the mount point choose /boot
    4.2 then 20GB for /
    4.3 and about 38 for /home
    4.4 give the rest to the swap

    then just keep click next next ... when i rebooted i found kali grub automatically instead of windows.

    PS: What i think caused me the problem in the first place is i didnt do this partitioning, what i mean is before that when i used the usual methods when kali is pre-installed it ask me where to save the grub bootloader and they give you 2 choices C drive in windows and the USB and when you choose C there something go wrong i think its about this UEFI bios and all that stuff
    i'm not certain why but thats the only answer i've got lol.
    anyway thank you again for your help and i considered your suggestion i loved the idea i may use it later

  7. #7
    Join Date
    It seems that we need to go abck to the basics and keep it simple! Don't try anything fancey, just let Kali install for you, stop the editing.
    try reinstall, Kali will detect the already installed version and replace it.
    afterwards, boot into windows and start a cmd prompt as admin.
    enter the command : bcdedit /set {bootmgr} displaybootmenu yes # this will enable dualboot mode for Windows and Linux
    any other issues pertaining to the boot manager should be resolved using bcdedit #Boot Configuration data Editor

Similar Threads

  1. Kali UEFI Installation on ASUS T100T
    By KSYSK in forum Installing Archive
    Replies: 5
    Last Post: 2016-03-24, 19:14
  2. installation probleme on nexus 5 lolipop 5.1
    By aurel in forum Installing NetHunter
    Replies: 2
    Last Post: 2015-10-20, 14:51
  3. Installation Failed, No Space Left, ASUS EEE PC 901
    By log_user in forum Installing Archive
    Replies: 1
    Last Post: 2015-09-15, 13:04

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts